Table of Contents

SECTION 1

Overview.................................................................... 5
Document Conventions ................................................................................5
Audio Processor Features............................................................................6
DFR22 Software Minimum Requirements ....................................................7
Interface Modes............................................................................................7
Design Mode......................................................................................................... 7
Live Mode ............................................................................................................. 7
Preview Mode ....................................................................................................... 7

The Main Window.........................................................................................8
Title Bar ................................................................................................................ 8
Control Bar............................................................................................................ 9
Signal Flow Diagram............................................................................................. 9
Status Bar ........................................................................................................... 11

The “Processor Toolbox” ............................................................................11

SECTION 2

Start-up Guide.......................................................... 12
Install the Software .....................................................................................12
Establish Communication with the Device .................................................12
Configure External Control .........................................................................13
Create a Preset Template...........................................................................14
Manage Your Presets .................................................................................15
Establish Security .......................................................................................16

SECTION 3

Creating a Preset..................................................... 17
Signal Flow Configuration ..........................................................................17
Gain Structure..................................................................................................... 17
Muting Channels................................................................................................. 18
Labeling Inputs and Outputs............................................................................... 18
Signal Routing .................................................................................................... 19
Naming a Preset ................................................................................................. 20

Processor Configuration.........................................................................

20

Processor Types ................................................................................................. 20
Adding Modular Processors................................................................................ 21
Copy and Paste .................................................................................................. 23
Deleting Processors from Slots .......................................................................... 23
Linking ................................................................................................................ 24
Bypassing ........................................................................................................... 25
Managing DSP Resources ................................................................................. 25

Default Presets ...........................................................................................27
Preset One – [Dual Mono] .................................................................................. 27
Preset two – [Stereo] .......................................................................................... 27
Preset Three – [Dual Mono Split]........................................................................ 27

© 2003 Shure Incorporated

DFR22 Software Guide

2

Table of Contents

SECTION 4

Preset and Device Management .........................

28

Preset Files ................................................................................................28
Saving a New Preset to Your Computer .......................................................... 28
Revising Preset Files .......................................................................................... 28

Device Presets ...........................................................................................29
Store a Preset in the Device ............................................................................... 29
Rename a Preset................................................................................................ 30
Delete a Preset ................................................................................................... 30

Device Backup ...........................................................................................31
The Devices Menu .....................................................................................32

SECTION 5

Processor Features ................................................. 33
Faders ........................................................................................................33
Saving and Recalling Settings....................................................................34
Naming Processor Windows ......................................................................34
Snapshots ..................................................................................................35
Importing ASCII Files .................................................................................36
Saving Files in ASCII Format.............................................................................. 36
Import Controls and Features ............................................................................. 37

Combined Response Graph...................................................................

SECTION 6

Fixed Processors .................................................

38

40

Input Gain...................................................................................................40
Matrix Mixer................................................................................................42
Output Gain ................................................................................................44

SECTION 7

Modular Processors ................................................. 46
Automatic Gain Control (AGC) ...................................................................46
Compressor/Limiter ....................................................................................50
Soft Knee Processors ......................................................................................... 53
Stereo Processors .............................................................................................. 54

Crossover/Splitter/Subwoofer.....................................................................55
Keyboard Controls .............................................................................................. 59

Cut and Shelf Filters...................................................................................60
Fine Tuning Parameters ..................................................................................... 62
Copy and Paste .................................................................................................. 63

Delay ..........................................................................................................64
Digital Feedback Reducer (DFR) ...........................................................

66

Basic DFR Setup ................................................................................................ 69
Filter Allocation ................................................................................................... 69
High Q Filters and Low Q Filters......................................................................... 70
Adding, Modifying, and Removing Filters ........................................................... 70
Copy and Paste .................................................................................................. 71
Auto Clear........................................................................................................... 71

© 2003 Shure Incorporated

DFR22 Software Guide

3

Table of Contents

Ducker ........................................................................................................73
Gate/Downward Expander .....................................................................

76

Graphic Equalizer.......................................................................................79
Parametric Equalizer ..................................................................................82
Working with Filters ............................................................................................ 85

SECTION 8

Control Pins ............................................................. 87
Control Pins Overview................................................................................87
Control Pins Tutorial ...................................................................................88
The “Control Pins” Window ........................................................................91
“Pin Configuration” .....................................................................................91
Preset Encoding Settings ................................................................................... 92
Connection Blocks .............................................................................................. 93

“Processor Mapping” ..................................................................................95
Mapping Hardware Controls to Input and Output Channels ............................ 95
Gain Control Settings.......................................................................................... 95
Creating a Processor Map .................................................................................. 96

SECTION 9

Security .................................................................... 98
Front Panel Lockout ...................................................................................98
Restricting Computer Access .....................................................................98
Establishing Device Security .............................................................................. 99
Changing Device Security .................................................................................. 99
Individual Processor Security ........................................................................... 101

SECTION 10

Printing Reports ..................................................... 102
Device Information ...................................................................................102
Preset Information and Current Preset Information..............................

103

Processor Information ..............................................................................103
Report Samples........................................................................................104
SECTION 11

Appendix A: Binary Encoding Tables....................................108

SECTION 12

Appendix B: DSP Usage Per Processor............................... 110

SECTION 13

Appendix C: File Extensions................................................. 111

SECTION 14

Appendix D: Troubleshooting Guide ..................................... 112
Communication fails between the computer and the DFR22: .......................... 112
DFR22 preset indicator displays the letter “E” followed by a number:.............. 112
Unable to switch device presets from the computer: ........................................ 113
Unable to switch presets from the device’s front panel:.................................... 113

© 2003 Shure Incorporated

DFR22 Software Guide

4

SECTION 1

Overview

The DFR22 Audio Processor with Feedback Reduction is a 2-input, 2-output digital audio processor. It is ideal for installed
sound reinforcement applications, such as houses of worship, theaters, and meeting facilities. The DFR22 is also a powerful setup tool in live music applications. Using the DFR22's drag-and-drop graphical user interface, processors can be
placed anywhere in the signal path. The 2-by-2 matrix mixer allows either or both inputs to be routed to either or both outputs, with additional controls for levels and polarity.

Document Conventions
The DFR22 software interface is so intuitive and user friendly that you may be tempted to skip reading this document and
immediately begin programming the unit. Before you do, however, you should at least skim this overview, then thoroughly
read the Start-up Guide on page 12. Any questions you have about the software will be answered in the following sections
of the document.

How this Guide is Organized
•

Overview . . . . . . . . . . .Introduces the main features of the Audio Processor, and discusses the operating
modes of the interface and the main window.

•

Start-Up Guide . . . . . . .Covers the basic steps you need to follow with the software to set up the Audio Processor for an installation.

•

Creating a Preset. . . . .Covers the elements of a DFR22 signal flow configuration, such as the gain structure
of the device, routing signal from inputs to outputs, adding processors to the signal path, and working with
them in the main window.

•

Preset and Device Management . Explains how to save a preset to the computer, store it in the DFR22, and
backup the contents of the device to computer. It also covers the features of the [Device] menu.

•

Processor Features. . .Covers the features that are common among many of the signal processor modules,
such as fader controls, taking snapshots of parameter settings, and saving and recalling settings to and from
the computer.

•

Fixed Processors . . . .Explains the features of the input and output gain blocks and the matrix mixer.

•

Modular Processors . .Explains the features specific to each of the drag-and-drop signal processors.

•

Control Pins. . . . . . . . .Describes the internal architecture of the Audio Processor's external device control
feature and explains how to configure the DFR22's control pins with the software once the external hardware
has been connected.

•

Security . . . . . . . . . . . .Covers the security features of the Audio Processor that restrict user access to device
settings and front panel controls.

Notation Conventions
•

Text in [brackets]. . . . . Denotes literal text in the software interface, such as control labels, buttons, or menu
commands.

•

Keyboard keys. . . . . . .Such as Shift, Ctrl, and Esc appear in bold face. When you need to press key combinations, or keys in combination with a mouse click, the plus sign is used like this: Ctrl + Click.
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Audio Processor Features

Audio Processor Features
The DFR22 is a 2-input, 2-output digital audio processor with a software interface and simple front panel controls, which
stores 16 presets. It provides 24-bit conversion, 48khz sampling and a minimum dynamic range of 100dB.

Drag and Drop Software Interface
The computer interface to the Audio Processor mimics the functional block diagrams used in sound system design.
This makes the software incredibly easy to learn, because the interface seems immediately familiar to sound professionals. Presets can be built and edited entirely by clicking, dragging, and dropping with the mouse. You can
configure the signal path with any combination of drag and drop signal processors.

Modular Signal Processors
Each signal processing module is encapsulated in a graphic block that you can manipulate with the mouse. After
you place a processor in the signal flow diagram you can access the processor settings by double-clicking on the
block to open its parameter window. Settings can be saved and recalled from the computer, and copied between
similar modules. Processor settings can also be synchronized via the link feature. The DFR22 Audio Processor
includes the following selection of signal processor modules.

•

Shure’s Powerful Digital Feedback Reducer, in
both Mono and Stereo Processors

•
•

Automatic Gain Control and

•

3- to 10-Band Parametric Equalizers with Cut
and Shelf Filters

Combining and Non-Combining 10- and 30Band Graphic Equalizers

•
•
•
•

2-Way Crossover and Splitter

•
•

Ducker

Subwoofer
Gate/Downward Expander
Mono and Stereo Compressor/Limiter with SoftKnee Option
Peak Stop Limiter

External Device Control
After it is installed and programmed with the software interface, end users can control the DFR22 with a computer
or an AMX or Crestron controller. In addition, the control pins on the rear panel can be connected to external hardware, so that the DFR22 will respond to contact closures, potentiometers, and wall-plate switches.

Security
The security feature gives the installer peace of mind that the device cannot be tampered with after it is installed.
User access can be completely restricted so that the user cannot change any settings, or use the front panel controls. They will only be able to view the settings of the current preset from the software interface. End-user control
can also be customized to allow access to certain settings, and not to others.
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DFR22 Software Minimum Requirements

DFR22 Software Minimum Requirements
The DFR22 Software Version 3 requires a PC with the following specifications to function properly:

•
•
•
•

20 MB available hard disk space
CD-ROM drive
VGA monitor with 640 x 480/256 color, or higher resolution
Mouse or other pointing device

Processor speed and memory requirements vary, depending on the version of Windows and number of background applications you are running. Operating the DFR22 software simultaneously with programs such as SIA-Smaart® or Gold Line TEF™
requires a faster processor and more RAM. The following table lists the minimum requirements for running the DFR22 software with no other applications in the background, including virus protection, firewall, instant messaging, or e-mail.
Windows Version

Processor Speed

RAM

98, Second Edition

Pentium 166 MHz

48 MB

NT

Pentium 233 MHz

64 MB

ME

Pentium 300 MHz

64 MB

2000 Professional

Pentium 300 MHz

96 MB

XP Professional, Home

Pentium 300 MHz

128 MB

Interface Modes
The Interface features two primary modes of operation: Design Mode and Live Mode. This provides you with the option of
creating configurations for the DFR22 regardless of whether or not the computer is connected to the device. There are certain functions that are specific to each mode, which are explained throughout the manual.

Design Mode
When you launch the application, you always begin in Design Mode. This is the mode you use to create presets
that are later stored in the DFR22. In this mode, it is not necessary for the computer to be connected to the device.
You can save the presets you create to your computer, which may later be recalled and sent to the device through
the RS-232 connection. This provides you with the capability to design presets in a location other than where the
equipment is installed.

Live Mode
This mode allows you to make real-time adjustments to hardware presets while the computer is connected to the
DFR22. This provides you with the means to instantly hear changes to signal processing as you alter settings, so you
can easily refine your presets on site. Everything you do in Live Mode is written directly to the current live preset.

Preview Mode
When working in Live Mode with a device that contains multiple presets, you may recall them individually for realtime modification. When you select a preset to load into the signal flow diagram, the window enters preview mode
to give you the opportunity to verify your selection before you designate it as the next live preset. The interface
returns to Live Mode when you load the preset, or cancel the operation.
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The Main Window

The Main Window
This window, shown below in Figure 1-1, is your primary work space in the software interface. You can size it proportionally larger, or maximize it to take up your entire screen. Closing this window exits the application.
1
2
3

4

5
FIGURE 1-1: Main Window
1.
2.

Title Bar: Displays device-specific information in Live
Mode. Refer to the section below for further description.

Signal Flow Diagram: The space in which you create
presets. Refer to the section on the following page for more
information.

Main Menu: Provides access to menu commands specific to the device and the signal flow diagram.

3.

4.

5.

Control Bar: Displays controls specific to the device and

Status Bar: Displays controls and indicators for the signal
flow diagram. Refer to the section on page 11 for more
information.

the signal flow diagram. Refer to the section on the following page for more information.

Title Bar
The information on the title bar of this window changes depending upon the operating mode. In Design Mode
the title bar reads, “DFR22: Offline,” and indicates the default security level. In Live Mode, it displays information specific to the unit to which you are connected, as illustrated below in Figure 1-2.
1

2

3

FIGURE 1-2: Title Bar
1.

Device ID: The device ID is specified by setting the DIP
switches on the back of the device. Refer to the Installation
Guide for instructions.

2.

3.

Security Level: In Live Mode this indicates the current
security level set for the device. For more information, refer
to the Security section on page 98.

Device Name: To name the device, in Live Mode select
[Devices>Name Device] from the main menu. For more
information refer to the Start-Up Guide, step 5 on page 13.
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The Main Window

Control Bar
This section of the window changes in appearance and function depending on the operating mode in which you
are working, as illustrated below.
Design Mode:

1

2

3

4

5

6

7

8

Live Mode:

9

10

Preview Mode:

11
FIGURE 1-3 Control Bar
1.

[Live Mode] Button: Click this button to switch to Live
Mode, which enables you to preview and edit any preset
currently stored in the hardware. Your computer must be
connected to the DFR22 to enter this mode.

2.

[Design Mode] Button: Click this button to switch to
Design Mode. The preset you were working with in Live
Mode remains loaded in the signal flow diagram.

3.

Information Box: This displays details about the preset

6.

[Save As] Button: Click this button to save the current
preset to your computer.

7.

[Open] Button: Click to load a preset file from your computer into the signal flow diagram.

8.

Preset Selector: Click this drop-down menu to select
from the list of presets that are stored in the device.

9.

in the device. They can be toggled on and off by clicking on
them or by selecting [View>Enable I/O Meters] from the
main menu.

that is currently loaded on the screen, including name, date
last saved, and description.
4.

[Store Preset] Button: Click to store the current preset
in the DFR22.

5.

[Recall Preset] Button: Click to load a preset from the
DFR22 into the signal flow diagram and work with it in
Design Mode.

LED Meters: These LED meters indicate the audio levels

10.

[Load] Button: Click to load the previewed preset into

11.

[Cancel] Button: Click to return to the previous

the signal flow diagram
preset.

Signal Flow Diagram
The signal flow diagram graphically represents how audio signals pass through the gain structure of the Audio
Processor and the processor blocks you put on the input and output channel strips. Each preset you create in
the signal flow diagram stores the configuration of processor blocks and signal routing connections you have
created. You can create presets in Live Mode or Design Mode and store them either in the device, or on your
PC. In Live Mode the preset that is loaded in the signal flow diagram is the current live preset. To designate a
different live preset use the drop-down preset selector in the information on box (#8 above).
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The Main Window

Mode Indicator
This displays the current mode of the signal flow diagram, as illustrated below.
Design Mode

Live Mode

Preview Mode

Input and Output Channel Strips
These strips are graphic representations of the input and output channels of the DFR22. They contain the
gain and mix blocks that make up the gain structure of the device, as explained in the Gain
Structure section on page 17. They also contain the slots in which you place the processor blocks, which
you can drag and drop from the “Processor Toolbox” (see page 11).
1

2

8

5

4

3

6

7

9

FIGURE 1-4: Input and Output Channel Strips
1.

2.

Input Gain Block: This is the initial stage of the Audio
Processor's gain structure. Double-clicking this block
opens the “Input Gain” window, which provides you with 10dBV/+4dBu scaling options, channel mute, polarity control, and a +10/-infinity dB fader for each input channel.
This is also where you name your input channels.

6.

Input Selectors: Click on these numbered input selectors at the mix point of each output strip to instantly route
the signal from the corresponding input channel mix point.

7.

Mix Block: This is the intermediate stage of the Audio
Processor's gain structure. Double-clicking this block
opens the “Matrix Mixer” window, where you can route signal from either input channel strip to either or both output
channel strips, and adjust levels with fader controls. This
window has a separate tab for each output channel strip
that displays gain, polarity, and mute controls for both input
channels.

8.

Output Gain Block: Double-clicking this block opens
the “Output Gain” window, which provides you with 10dBV/+4dBu scaling options, channel mute, polarity control, a -12dB and 18dB pad, and a +10/-infinity dB fader for
each output channel. This is the final stage of the Audio
Processor's gain structure. This is also where you name
your output channels

9.

Output Channel Label: This displays the channel label

Input Channel Label: This displays the channel label
that you specify in the “Input Gain” window.

3.

Processor Slot: These slots are containers for the modular processor blocks. You can populate them with processors either by using the drag and drop method from the
“Processor Toolbox,” selecting the [Processor>Add] option
on the main menu, or by clicking the right mouse button
and selecting the [Add Processor] option from the contextual menu.

4.

Mix Points: Click on these points to route signal between
input strips and output strips. Lines appear between points
that are connected, representing the signal flow. Each input
strip may be connected to either or both output strips.

5.

Channel Numbers: These numbers correspond to each

that you specify in the “Output Gain” window.

of the input and output channels.
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The “Processor Toolbox”

Status Bar
This is the bottom section of the “Main Window.”

1

2

4

3

FIGURE 1-5: Status Bar
1.

Mute Inputs: Click this control to instantly mute both

placed in the signal flow diagram. The meter displays a
green bar that expands as DSP usage increases

input channels.
2.

Mute Outputs: Click this control to instantly mute both
output channels.

3.

DSP Usage Meter: This indicates the percentage of the
DFR22's digital signal processing resources that is used by
the current configuration of processor blocks that you have

4.

Delay Memory Meter: This indicates the percentage of
delay memory that is used by the delay processors you
have placed in the signal flow diagram. The meter displays
a blue bar that expands as usage increases.

The “Processor Toolbox”
The “Processor Toolbox” appears next to the main window when you launch the application, as shown in Figure 1-6.
This window displays the library of processors that you can drag and drop onto empty slots in the signal flow diagram.
It can be resized vertically by dragging the top or bottom edge up or down. A scroll bar appears on the right-hand side
so you can access every processor block, regardless of the height of the window.

Showing and Hiding
You can close the “Processor Toolbox” by clicking on the [X] in the righthand corner of the title bar, or by selecting [View>Show Processor Toolbox] from the main menu. To re-open the “Processor Toolbox,” select
[View>Show Processor Toolbox] again. A check mark appears next to the
menu option when the “Processor Toolbox” is open.

Features
1.

Drop-Down Buttons: A drop-down button appears over each processor category in the “Processor Toolbox.” Click on a drop-down button
to show or hide all processor blocks within that category.

2.

Processor Blocks: Processor blocks are the graphical representation
of processor modules. After you place them on the signal flow diagram,
you can access their settings by double-clicking on each block to open
its parameter window. The percentage of digital signal processing resources that each processor module uses is displayed to the right of
the blocks in the “Processor Toolbox.”
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SECTION 2

Start-up Guide

The Start-Up Guide covers the basic steps required for complete set up of the Audio Processor. Before attempting to follow
these instructions, you should familiarize yourself with the Overview section, which introduces some basic features of the
software interface.
You can perform many of these steps without actually being connected to the device, by saving your presets to the computer and transferring them to the hardware at a later time. In order to acquaint you fully with the features of the DFR22,
these instructions are written presuming the following conditions:

•
•
•

You are working while connected to the device.
The installation includes external device control.
Device security is required.

You may find steps in the instructions that do not apply to your immediate installation. However, we suggest that you follow
along through the entire Start-Up Guide, in order to acquaint yourself with the recommended workflow of setting up the
device, for future reference.

Install the Software
If you have not already installed the software, follow these instructions to install the application from the CD-ROM.
To install the software from the CD-ROM:
1.

Insert the CD into the CD-ROM drive of your computer.

2.

The installation program will start automatically. Follow the on-screen instructions.

If installation does not begin automatically:
1.

Click on the [Start] button on the Windows Taskbar and select [Run...] from the pop-up menu

2.

Type “D:\setup” (where “D” is your CD-ROM drive).The installation program will start automatically. Follow the
on-screen instructions.

3.

Click [OK] and follow the instructions of the installation program.

If you have downloaded a copy of the software, locate the “.exe” file in the Windows Explorer and open it. Follow the
instructions of the installation program.

Establish Communication with the Device
This is the procedure to use when you initially connect the computer to the device. It is your first opportunity to verify that
your computer and the DFR22 are communicating properly. For more information on connecting your computer to the
device and setting the device ID, see the Installation Guide.

1. Connect the Computer to the DFR22 Audio Processor
Connect your computer’s COM port to the RS-232 port on the front or rear panel
of the DFR22.

2. Launch the Software Application
3. Select the COM Port
a) Select [Devices>Select COM Port] from the main menu.
b) The “COM Port” dialog opens, as pictured in Figure 2-1.
c) Choose the COM port to which the RS-232 cable is connected and
click [OK].
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Configure External Control

4. Click the [Live Mode] button on the Control Bar
5. Name the Device
a) Select [Devices>Name Device] from the main menu.
b) The “Name Device” dialog appears, as pictured in Figure 2-2.
c) Enter a device name up to fifteen characters long and click [Name].
d) The device name appears on the title bar of the main window when you are
in Live Mode, and is listed in the [Devices] menu.
FIGURE 2-2: “Name Device” Dialog

Configure External Control
If there are external devices connected to the control pins, you need to configure the DFR22 to recognize the external
controllers. This configuration is stored at the device level and should be established before you create any presets. If
you are not connected to the device, you can create a configuration and save it on the computer to be later transferred to the DFR22 through the RS-232 connection. Refer to the Control Pins section on page 87 for complete stepby-step instructions.
Note:

By default you can select presets with the preset selector on the front panel of the DFR22.

1. Enter Design Mode
You must be in Design Mode to configure external control. If you are in Live Mode, click the [Design Mode] button
on the control bar of the main window.

2. Configure Control Pins
Select [Devices>Control Pin Configuration] from the main menu, which opens the “Control Pins” window.
a) Specify the number of presets you will be selecting via external control in the [# Presets] field.
b) Select the type of encoding the DFR22 must use to recognize the external hardware messages in the [Encoding Type] field.
c) If necessary, specify the other hardware connected for channel muting and gain control, such as potentiometers and switches.

3. Save the Configuration to the Device or to PC
Select the [Configuration>Store to Device] or [Configuration>Save to PC] menu option.
Note:

If you need to switch presets from the computer after you have configured the control input connections, you must disable the connections in the “Control Pins” window before proceeding further. Click
the arrow on the right side of the preset control block and select [Disable] from the drop-down menu.
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Create a Preset Template
This can be done in either Live Mode or Design Mode. When you are storing multiple presets in the Audio Processor, you
will save considerable time by creating a preset template that contains the attributes that will be common among them. This
template can then be recalled from the device or opened from a PC, revised as necessary, then stored in the device each
time as a new preset.

1. Select a Preset Template
When you start the DFR22 application there is a blank preset in the signal flow diagram. If you would like to use
one of the other default presets as a template, select [File>New] from the main menu and then select [Dual Mono],
[Stereo], or [Dual Mono Split]. You can also go to Live Mode and select one of the pre-loaded presets to edit. For
more information, refer to the Default Presets section on page 27.

2. Name Input and Output Channels
Double-click on the input and output gain blocks to open the processor parameter windows, and edit the channel
labels that appear underneath the gain controls. For more information, refer to the Labeling Inputs and
Outputs section on page 18.

3. Populate the Signal Flow Diagram
Drag and drop signal processor blocks from the “Processor Toolbox” onto the signal flow diagram. If you are using
a crossover, it should be the first type of processor that you place in the configuration, followed by limiters, in order
to prevent loudspeaker damage. For more information, refer to the Adding Modular Processors section on
page 21.

4. Create Link Groups
Ctrl + Click to select multiple processors of the same type that you would like to control as a group, for stereo
pairs, loudspeaker clusters, zones, etc. You can also link gain blocks in order to control overall system level. Select
[Processor>Link] from the main menu. For more information, refer to the Linking section on page 24.

5. Engage Pads on Outputs
You may need to engage the 12dBor 18dB pad to better align the output clipping level of the DFR22 with the input
clipping level of the equipment to which it is connected. Double-click on an output gain block to open the “Output
Gain” window and click to activate each pad as needed.

6. Route Signal From Inputs to Outputs
Click and drag from input strip connection points to output strip connection points to route the signal through the
matrix mixer. For more information, refer to the Signal Routing section on page 19.

7. Adjust Processor Settings
Double-click on each processor block to open its parameter window. If you are working off-line in Design Mode,
you can set preliminary levels and tweak them later when you are connected to the device. For more information
on working with processors, refer to the Processor Features section on page 33, as well as the reference section
for each processor.

8. Map the Preset to Control Connections
This step is applicable only when you are controlling gain and/or channel muting via the control pins. Select
[Devices>Control Pin Configuration] from the main menu to open the “Control Pins” window. Select [Configuration>Recall From Device] to populate the window with the current pin configuration. The input and output channels
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Manage Your Presets

are listed in a column under each connection block. Click the checkbox next to each input or output channel you
wish to map to the control connections. For more information, refer to the “Processor Mapping” section on page 95.

9. Lock Processors for Read-Only Access
This step is applicable only when you are customizing security for end users accessing the DFR22 from the software. This type of security is stored with each processor, at the preset level. Select the processors that the user
should not be able to modify, and select [Security>Level 2>Lock Selected] from the main menu. For a complete
explanation and further instructions, refer to the Individual Processor Security section on page 101.

10. Name the Preset
Click once with the left mouse button anywhere in the information box in
the center of the control bar to open the “Preset Information” dialog, as
pictured on the right in Figure 2-3. Enter a name for the preset, up to 15
characters long, and a description, then click [OK]. For more information,
refer to the Naming a Preset section on page 20.

Manage Your Presets
1. Store the Finished Preset in the Device

FIGURE 2-3 “Preset Information” Dialog

If you are working in Live Mode, the preset is already stored in the
device. If you are working in Design Mode, click the [Store Preset] button on the control bar of the main window.
For more information, refer to the Device Presets section on page 29. To duplicate this preset you need to be in
Design Mode. Simply continue to click the [Store Preset] button, creating duplicates until you have stored as many
presets in the device as you require.

2. Delete Unused Presets from the Device
The device comes pre-loaded with three presets. If you are not going to use them, you should delete them from the
device so end users cannot access them. (If you need them again later, you can recall them from the [File>New]
menu.) See the Delete a Preset section on page 30 for instructions.

3. Enable External Control
Once you are finished creating and editing presets, if you previously disabled control connections in order to control the Audio Processor via the computer, open the Control Pins window and re-enable them. See the IMPORTANT NOTE ON PRESET SWITCHING: section on page 88 for more information.
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Establish Security
This is the final step in setting up the device. Before continuing, you should thoroughly read the Security section on
page 98. These instructions are intended only as an overview of the process.

1. Go Live with the DFR22
You must be in Live Mode to set device security. If you are in Design Mode, click the [Live Mode] button on the
control bar of the main window.

2. Set the Front Panel Lockout
Select [Security>Front Panel Lockout] from the main menu, which opens the “Front Panel Lockout” dialog. Select
the checkbox next to each front panel feature for which you wish to lockout end user access. Use this software feature to selectively lock out front panel controls. To lock out all front panel controls you can also set the fifth DIP
switch on the back of the device to the down position.

3. Set a Password
Select [Security>Set Password] from the main menu, which opens the “Create Password” dialog. Type in a password, press Tab, and then type it again to confirm. Click [OK].

4. Set the User Access Level
Select [Security>Set Level] from the main menu, which opens the “Set Security” dialog. Select the appropriate user
access level. Click [OK].
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SECTION 3

A preset is a unique combination of signal routing connections, the variety and placement of modular processors, and the
processors’ settings. You create the configuration in the signal flow diagram of the main window, and either save it as a
preset in the device, or save it to the computer as a file that you can send to the device later.

Signal Flow Configuration
In order to pass audio through the device, you must route signal from the inputs to the outputs by connecting mix points.
This section explains the basics of signal flow design in the DFR22 user interface.

Gain Structure
The DFR22 Audio Processor provides gain control at three stages of the signal flow: input gain, matrix mixer, and
output gain. It is essential to obtain an understanding of this gain structure before passing audio through the unit, in
order to avoid damaging equipment that is in line after the Audio Processor with excessive gain levels. The following illustration provides an overview of the DFR22 gain structure.
4

1

2

3

FIGURE 3-1: Gain Structure Diagram

1) Input Gain
Double-clicking on either input gain block will open the “Input Gain” processor window, which displays controls
for both channels. It provides input sensitivity, gain and polarity control for each channel, and allows you to
specify custom names for your input channel strips.
Note:

Signal levels exceeding the input threshold of the Audio Processor must be adjusted externally to prevent
clipping at the A/D converters.

This is a signal's point of entry to the signal flow diagram. After the input gain processor, the signal passes
sequentially through the processor slots on its input channel strip. At the end of the channel strip, the signal
arrives at a mix point, where it can be routed to either or both outputs via the matrix mixer.

2) Matrix Mixer
Once a signal has been routed to the mix point of an output channel strip, it enters the matrix mixer stage of the
gain structure. Double-click on any mix block to open the “Matrix Mixer” processor window, which displays a
pane for each output channel strip. When the crossover or splitter is placed over both output channels, the
mixer panes for those channels will combine into one. Use this window to adjust the polarity and relative levels
of the input(s) routed to the selected output channel.
After the matrix mixer, the signal passes sequentially through the processor slots on the designated output
strip. At the end of the channel strip, the signal arrives at the output gain block.
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3) Output Gain
This is the final stage of gain control in the Audio Processor. Double-click on any output gain block to open the
“Output Gain” processor window. It provides output sensitivity, gain, polarity control, and an optional 12 dB and
18 dB pad for each channel. This window also allows you to specify custom names for your output channel
strips. After the output gain processor the signal passes through the D/A converter, then through the analog
pads (if engaged), to the audio output.

4) Signal Routing Connection
This can be created in the signal flow diagram by clicking and dragging between mix points, by clicking on an
input selector directly to the left of the MIX block, or by opening the “Matrix Mixer” window and selecting the
input. For more information see the Signal Routing section on page 19.

Muting Channels
There are several ways to mute the input and output channels of the Audio Processor. Muted channels are flagged
in the signal flow diagram, as illustrated in the following table.
Gain Block

Inputs to
Matrix Mixer

Crossover Output
Channels

Muting all Inputs or Outputs
• Click either the Mute All Inputs or Mute All Outputs control located on the status bar of the
main window.
Inputs and Outputs Muted

•
•

Select either the [Processor>Mute All Inputs] or the [Processor>Mute All Outputs] menu option.
Power off the device to automatically mute all outputs.

Muting Individual Channels
1.

Open the “Input Gain,” “Matrix Mixer,” “Crossover,” or “Output Gain” window by double-clicking the appropriate processor block.

2.

Click the mute button for the appropriate channel.

3.

The block will be flagged with a red “M” to indicate that it is muted.

Labeling Inputs and Outputs
Inputs and outputs are untitled when you create a new preset, but they are easily changed using the “Input Gain”
and/or “Output Gain” windows. Channel labels are saved along with the preset, so you can customize input and
output labels for every preset.
To change a channel label:
1.

Double-click on the channel's gain block.

2.

In the processor window, locate the channel's label box.

3.

Click and drag over the text to highlight it.
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4.

Type in a new label of no more than fifteen characters.

5.

Apply the changes by clicking on another control or closing the window.

Signal Routing
The DFR22 allows you to route signal from either of the two inputs to either or both of the outputs. In order for signal to pass from the input channel strips to the output channel strips, it must be routed through the matrix mixer.
You can connect inputs to outputs using any of the methods described below.

Making Connections in the Signal Flow Diagram
For simple system configurations, the easiest way to connect inputs to outputs is to use the mouse in the signal flow diagram.
Click on Mix Points:
1.

Click on an input mix point.

2.

The cursor will change to indicate it’s waiting
for you to specify an output connection:

3.

Click on an output mix point.

Tip!

You can use the Esc key to cancel a connection if you change your mind after you have
clicked on an input mix point, before you click on an output mix point.

Click and Drag Between Mix Points:
1.

Click and drag from an input mix point to an output mix point.

2.

A connection line will appear along the signal path. It turns green when the connection is valid.

3.

Release the mouse button to make the connection.

Click on the Input Selectors:
1.

Click on an output channel's numbered input selector for the corresponding
input channel.

2.

A connection line will appear in the signal flow diagram between the mix points, and
the numbered input selector will be highlighted.

Making Connections in the “Matrix Mixer” Window
For more complex configurations with many crossing connection lines, the “Matrix Mixer” window can provide
an easier method of connecting inputs to outputs.
To make connections in the “Matrix Mixer” window:
1.

Double-click on the mix block for the output you wish to connect.

2.

The “Matrix Mixer” window opens.

3.

In the left side of the window, click the input button for each input channel you wish to connect to the
selected output. The input button lights green when a connection is made.

4.

A connection line will appear in the signal flow diagram between the mix points, and the numbered input
selector will be highlighted for each active connection.

Deleting Connections
• Click on a connection line and press the Delete key.
• Click on the input selector corresponding to the connection. This toggles the connection off.
• Click on a connection line and use the right-click contextual menu.
• Select multiple connections by holding down the Ctrl key while clicking on the connections, then press the
Delete key.
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Naming a Preset
Since you can store up to 16 different presets in the DFR22, it can be helpful to differentiate them with a name and
a brief description. The information box in the center of the control bar of the main window displays these details,
as pictured below in Figure 3-2.

FIGURE 3-2: The Information Box

The name you enter here becomes both the name of the preset when you store the configuration to the device,
and the name of the file when you save it to PC. The description will also be displayed in all the dialog boxes that
list presets. You can revise these details at any time in either Live Mode or Design Mode.
To name a preset:
1.

Click once with the left mouse button anywhere in the
information box.

2.

The “Preset Information” dialog opens.

3.

Enter a name with a maximum of 15 characters and a description
with a maximum of 80 characters.

4.

Click [OK]

5.

The information box updates to reflect your changes.

Processor Configuration

FIGURE 3-3: “Preset Information” Dialog

There are two levels of working with processors: at the configuration level in the signal flow diagram, and within each
processor's individual parameter window, which is accessed by double-clicking on the processor block. This section
covers working with processors in the signal flow diagram, and explains the differences between the two main categories of processors.

Processor Types
You will be working with two main types of processors in the signal flow diagram: fixed and modular. The primary
distinction between them is that fixed processors are part of the gain structure of the DFR22, and are therefore part
of every signal flow configuration. Modular processors are the processor blocks that are listed in the “Processor
Toolbox,” and that you can select and position to suit your particular system requirements.

Fixed Processors
The gain and mix blocks are called fixed processors because their locations on the channel strips are permanent. They cannot be deleted, moved, copied, or pasted. However they can be linked, and their settings can be
saved and recalled.

Modular Processors
The modular processor blocks are called modular because they can be placed on any empty slot (excepting
the crossover, splitter, subwoofer and the ducker), and freely moved, copied, pasted and deleted. Each processor block on the signal flow diagram functions independently. When you open the parameter window of a
modular processor, you are changing settings for that block only, except under the following conditions.

•
•

It is half of a stereo pair.
It is assigned to a link group.
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Adding Modular Processors
Each channel strip has a row of empty slots that can contain any of the modular processor blocks. Except for the
crossover, subwoofer, splitter, and ducker, there are no restrictions on where processors can be placed on the signal flow diagram, or how many times you can use a given processor on the same channel strip. Empty slots
between processors do not affect the signal flow, so blocks do not have to be adjacent on the channel strips.
When processor blocks are first added to the signal flow diagram, they contain factory default settings. You can
individually change each processor's settings by opening its parameter window. The blocks will retain their settings
even when copied or moved to a different slot.
Processor blocks can be added to the signal flow diagram either by using the “Processor Toolbox,” or by menu
command. Each method is described below.

Using the “Processor Toolbox”
You can use the mouse to grab a processor block from the “Processor Toolbox.” The mouse cursor will
change to alert you that your next mouse action will place the block in the signal flow diagram. The cursor's
appearance depends on its location, as illustrated in the following table.
Location where processor
can be placed.
Inappropriate location for
that processor.
To add a processor block from the “Processor Toolbox:”
1.

Point and click on a processor block in the “Processor Toolbox.”

2.

Hold the mouse button down and drag the block to the signal diagram.

3.

Release the mouse button to place the block at the current cursor location.

- OR 1.

Point and click on a processor block in the “Processor Toolbox.”

2.

Click on the appropriate empty slot in the signal flow diagram.

Tip!

If you change your mind after you have clicked on a processor block in the “Processor Toolbox” window, you can use the Esc key to cancel this operation before you place the processor in the signal
flow diagram.

Using a Menu Command
You can add processors to the signal flow diagram without opening the “Processor Toolbox,” by using either
the main menu or the right-click contextual menu, as described below.
To add a processor block using the menu:
1.

Click to select an empty slot.

2.

Use the right-click contextual menu to select a processor.
- OR Use the [Processor>Add] option on the main menu bar.

Another advantage to using a menu command to place your processor blocks is that you can place the same
type of processor in multiple slots with a single menu command.
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To add multiple processor blocks at once:
1.

Ctrl + Click to select multiple empty slots.

2.

Use the right-click contextual menu to select a processor.
- OR Use the [Processor>Add] option on the main menu bar.

3.

The processor will populate all the slots that you selected.

Stereo Processors
Stereo processors are placed in the signal flow diagram in much the same way as the other modular processor
blocks. However, each of the stereo channels appears as a separate block. Double-clicking on either block will
open the parameter window for both channels.
Each of the following processors operate as a stereo pair:
Block Name

Description

ST DFR 5

Stereo 5-Band DFR

ST DFR 10

Stereo 10-Band DFR

ST DFR 16

Stereo 16-Band DFR

ST COMP

Stereo Compressor

Sft ST COMP

Stereo Soft-Knee Compressor

ST LIM

Stereo Limiter

Sft ST LIM

Stereo Soft-Knee Limiter

To add a stereo processor block from the “Processor Toolbox:”
1.

Click on a stereo processor block in the “Processor Toolbox.”
When you select a stereo processor from the “Processor Toolbox,” the cursor will appear somewhat differently than it does for other processors, as pictured in the following table.
Location where the first channel of the
stereo processor can be placed.
Location where the second channel of the
stereo processor can be placed.

2.

Add the first channel of the stereo pair using one of the following methods.
a) Click and hold the left mouse button to drag a processor block from the “Processor Toolbox” to the signal flow diagram.
b)

Release the mouse button to place the first processor channel at the current cursor location.
- OR -

a) Click once on a processor block in the “Processor Toolbox.”
b) Click again on the appropriate empty slot in the signal flow diagram.
3.

The cursor changes to indicate you must place the second channel of the processor.

4.

Click on the appropriate slot to add the second stereo channel.

To add a stereo processor using the menu:
1.

Ctrl + Click to select empty slots on two different channels.

2.

Use the right-click contextual menu to place both channels of the stereo pair.
- OR Use the [Processor>Add] option on the main menu bar.
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Replacing Processors
Only one processor block at a time can occupy a given slot. To replace an existing processor with another, first
delete it from the slot then add the new processor using any of the methods described above.

The Crossover, Splitter, and Subwoofer
Since they are output processors, the crossover, splitter, and subwoofer can only be placed on output channel strips. They can be added to output strips like any other processor block, but you must take into account
the following:

•
•
•
•
Note:

The crossover extends downward to span both outputs, so you must place it on channel one.
The mix point will disappear from the second channel after the crossover is placed above it.
Processor slots will disappear from the second channel, to the left of the crossover block.
The splitter will affect the signal diagram as listed above for the crossover.
If your configuration calls for a crossover or splitter, it should be added to the signal
flow diagram before you connect mix points or add other processors to the output
channel strips.

The Ducker
The ducker should be placed only on the input channel strip that carries the paging signal. You are restricted
from placing a ducker on an output strip.

Copy and Paste
The traditional copy, cut and paste commands function only on the modular processor blocks. This is a convenient
way to duplicate processor blocks along with their settings across multiple channels.
To copy and paste a processor block:
1.

Point and click to select a processor block.

2.

Select the copy command using one of the following methods:

•
•
•

Use the right-click contextual menu.
Select [Edit>Copy] from the main menu.
Press Ctrl + C on the keyboard.

3.

Point and click to select an empty slot.

4.

Select the paste command using either the main menu, the right-click menu, or press Ctrl + V.
Note:

These commands do not function with multiple selections.

Deleting Processors from Slots
Modular processor blocks can easily be removed from a configuration without affecting any other aspect of the
signal flow.
To delete a processor block:
1.

Point and click to select a processor block.

2.

Select the delete command using one of the following methods:

•
•
•

Use the right-click contextual menu.
Select [Edit>Delete] from the main menu.
Press the Delete key.
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Linking
You can link multiple processor blocks of the same type in order to control them as one. Changes made in the processor parameter window of any block in a link group will simultaneously change the settings of every other block
in that group. There are a few activities, however, that will still function independently on linked blocks:

•
•
•

Delete, Copy, Cut and Paste,
Moving the block to a different slot or channel strip,
Naming the processor parameter window.

Fixed processors at the same stage of the gain structure can also be grouped, which will synchronize the level
controls for all of the grouped channels. For example, you can group two input channel gain blocks in order to control them as a stereo pair. You can also link both output gain blocks, in order to adjust the output channel levels
overall from a single control.
Note:

Only processors of precisely the same type can be linked.

Creating a Link Group
When you first create a link group, all of the processors in that group will synchronize to the same settings. If
you have already specified settings for one of the processors prior to creating the link group, you can designate it as the source when you first create the group, causing the other processor blocks to inherit those settings. Alternately, if you would like to discard any previous processor settings, you can select the factory
default settings as the initial source. After the link group is created, changes to settings of any of the linked
blocks will affect all blocks in that group.
To create a link group:
1.

Ctrl + Click to select multiple processor blocks.

2.

Select [Processor>Link>New Link Group from the main menu, or
[Link>New Link Group] from the right-click contextual menu.

3.

The “Create Link Group” dialog appears, as pictured to the right
in Figure 3-4.

4.

Enter a two-character name for the link group.

5.

Choose a source for the initial link group settings.

6.

Click [OK] to accept the settings.

The two-character link group name appears both on the processor
block in the signal flow diagram, and in the link indicator at the lower
right-hand corner of the processor parameter window, as illustrated
in the following table.
Processor Parameter Window

Note:

FIGURE 3-4: “Create Link Group” Dialog

Signal Flow Diagram

Processors can belong to only one link group at a time.

Adding to a Link Group
Processor blocks can be added to an existing link group, if they are the exact same type of processor and they
are currently unlinked. Any processor added to a link group will inherit the group's current settings.
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To add blocks to an existing link group:
1.

Click to select a processor block, or Ctrl + Click to select multiple
blocks.

2.

Select [Processor>Link>Add To] from the main menu, or
[Link>Add To] from the right-click contextual menu.

3.

The “Add to Link Group” dialog appears, as shown in Figure 3-5.
It lists only the link groups that contain processors identical to the
selected block.

4.

Select a link group.

5.

Click [OK]

FIGURE 3-5: “Add to Link Group” Dialog

Unlinking Processor Blocks
Processor blocks can be removed from a link group without affecting other linked blocks. You can also dissolve a link group by unlinking all the blocks in the group.
To remove blocks from an existing link group:
1.

Click to select a processor block, or Ctrl + Click to select multiple blocks.

2.

Select [Processor>Link>Unlink] from the main menu, or [Link>Unlink Selected] from the right-click contextual menu.

Note:

A link group must contain at least two processor blocks. Removing all but one block from a link
group will delete the group.

Bypassing
From the main window, you can bypass any modular processor block. This lets you evaluate the signal path while
temporarily excluding a processor. Bypassed blocks in the signal flow diagram display a yellow flag, as shown in
Figure 3-6.
To toggle bypass on or off:
1.

Click to select a processor block, or Ctrl + Click to select multiple blocks.

2.

Activate bypass with any of the following methods:

•
•
•

Press Ctrl + B on the keyboard.
Select [Processor>Bypass Selected] from the main menu.
Select [Bypass Selected] from the right-click contextual menu.

FIGURE 3-6: Bypassed
Processor Block

Managing DSP Resources
Although the DFR22 has sufficient processing power for many applications, it is possible to populate the signal
flow diagram with more processor blocks than the device's DSP (digital signal processing) resources can handle.
This section explains in general terms how the Audio Processor manages the signal processing requirements of a
configuration, and gives you some hints on how to get the most out of the DSP resources.

Resource Allocation
By placing a processor block on a channel strip, you are allocating the DSP resources necessary for it to run at
its maximum capacity. This is why so many varieties of the same type of processor blocks are provided; so that
you can select only the amount of processing you actually need for a given module. When you are designing a
simple configuration, it is not critical to pay attention to how much DSP is being utilized. However, the more
complicated the configuration, the more important it is to select processor blocks that use the minimal processing resources necessary to get the job done.
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For example: when you place a ten-band parametric EQ on a channel strip, you will instantly allocate the processing power required by all ten filters, even if you are only using four of them. The PEQ5 would be the best
choice, in this instance.

Delay Memory
The DFR22 has a memory buffer that will hold up to 10 seconds of delay time, which you can divide among
any combination of delay processors. Like DSP resources, delay memory is allocated to each processor block
according to the maximum delay time indicated in the block name.
For example, if you need 45 ms of delay, don't use the 2-second delay when the 150ms delay will do just as
well. Even though both processors may be set to the same values, the DLY 2s block still occupies a full two
seconds of delay memory.
Note:

Do not confuse delay memory with DSP resources. Each delay utilizes the same amount of DSP,
regardless of its maximum delay time.

DSP Usage Meters
These meters, located on the status bar at the bottom of the main window, indicate the amount of DSP
resources and delay memory utilized by the current configuration. Knowing the amount of DSP resources and
delay memory you have left enables you to manage your processor choices efficiently. When you add or
remove a processor block from the signal flow diagram the DSP meter instantly compiles the results, and indicates the system resources that are being utilized by the current processor configuration.

DSP Optimization Hints
If the message box shown in Figure 3-7 appears when you attempt to
add a processor, optimize your configuration to free up DSP
resources, then add the processor. The following hints will help you
optimize DSP resources.

•

Replace DFRs with parametric EQs after you are finished ringing
out the system.
For example: in a configuration where multiple DFRs are needed
on multiple inputs for better gain before feedback performance,
you could initially use a DFR on each input for ringing out the system. After the filters are deployed, copy the DFR filters and paste
FIGURE 3-7: DSP Resources Exceeded
them in a PEQ, then delete the DFR. You can repeat this for the
other input, then leave only the DFRs that are necessary for automatic feedback detection after the system has been configured. For more information on copying and
pasting filters between processors, see the Copy and Paste section on page 71.

•

Consolidate multiple EQs on the same signal path into a single module, if possible.
Example: two PEQ3s consume more DSP than a PEQ7. Note that all PEQ's are available with cut and
shelf filters in order to conserve DSP. If you don't require the additional slope choices of the CUT/SHELF
processor, it is not necessary to include cut and shelf filters in a separate module on the same signal path.

•

Consolidate multiple delays on the same signal path into a single module, if possible. Using two DLY5ms
blocks to achieve 7 ms of delay uses twice as much DSP than a single DLY150ms block, even though it
conserves Delay memory.

•
•
•

Remove processors from any unused channels.
Use the splitter to consolidate identical signal processing on both output channels.
Use a PEQ10 instead of a GEQ30. In most cases, you will not use all thirty filters on the GEQ30, and the
PEQ10 uses less than half as much DSP.
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Default Presets
To help you get started with basic configurations, the DFR22 comes loaded with three default presets. These presets are
also listed in the [File>New] sub-menu, so you can use any of them as a template to create a new preset.
Note:

You should either lock out the front panel preset selector or delete the default presets in the
device that you are not using so end users do not access them by mistake.

Preset One – [Dual Mono]
In this configuration input one is routed to output one and input two is routed to output two. Each input strip is populated with the following processors:

•
•
•
•

DFR16 - assigned to the front panel controls
PEQ10+CS
GEQ30
LIM

In addition, each output strip has a 2-Second Delay, set to 0ms by default.

Preset two – [Stereo]
In this configuration input one is routed to output one and input two is routed to output two. The input channels are
linked, as are the output channels, so you can control gain on both channels simultaneously at both the input and
output stages of the gain structure.
The input strips are populated with the following processors:

•
•
•
•

Stereo DFR16 - assigned to the front panel controls
Linked PEQ10+CS’s
Linked GEQ30’s
Stereo Limiter

In addition, the output strips are populated with linked 2-Second Delays, set to 0ms by default

Preset Three – [Dual Mono Split]
In this configuration input one and input two are each routed to both output one and output two. The input strip is
populated with the following processors:

•
•
•
•

DFR16 - assigned to the front panel controls
PEQ10+CS
GEQ30
LIM

In addition, each output strip has a 2-Second Delay, set to 0ms by default.
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SECTION 4

In Design Mode after you create a preset, you can save it either to the computer, or to the device, depending on whether or
not you are connected to the DFR22. At any time, one and only one preset is active in the DFR22. This preset is referred to
as the live preset. When you are in Live Mode, the preset you are viewing or modifying is the current live preset. You can
save it to the PC at any time by clicking the [Save As] button on the control bar of the main window.

Preset Files
You can design an entire library of presets with the DFR22 software without being connected to the device. Presets saved
to PC can be later recalled, revised, and then sent to the device. They are saved with a “.d22” file extension.

Saving a New Preset to Your Computer
If you are not connected to the device, you will be saving each new preset to the computer.
To save a new preset to the computer:
1.

In the main window, select [File>Save As] from the main menu or click the [Save As] button on the
control bar.

2.

The “Save As” dialog will appear.

3.

Navigate to the drive and directory location for the new file.

4.

Type in a file name and, optionally, a description.

5.

Click [Save].
Note:

The first fifteen characters of the file name and the first 80 characters of the description
appear in the information box on the control bar.

Revising Preset Files
When you make changes to an existing preset, you can either save it to PC with a different file name, or overwrite
the previous version.
To revise a preset stored on the computer:
1.

In the main window, select [File>Open File] from the main menu or click the [Open] button on the control bar.

2.

The “Open” dialog will appear.

3.

Navigate to the drive and directory location of the preset file you wish to open.

4.

Click on the file to select it, then click the [Open] button.

5.

Make the necessary changes.

6.

Select [File>Save As] from the main menu or click the [Save As] button on the control bar.

7.

The “Save As” dialog will appear.

8.

Click on the original file name to select it, then click [Save].

9.

A dialog box will appear that prompts you to verify that you want to overwrite the previous preset file.

10.

Click [Yes] to overwrite the file.
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Device Presets

Device Presets
The DFR22 can store 16 presets in its device memory. Once presets are stored in the device, they can be renamed,
deleted, or backed up as a set.

Store a Preset in the Device
When you are connected to the device, in Design Mode you can store new presets in the device, or open existing
preset files and store them to the device.
To store a preset in the device:
1.

In the main window, select [File>Store As Preset] from
the main menu, or click the [Store Preset] button on the
control bar.

2.

If the “Select Devices” dialog appears, as pictured in
Figure 4-1, select a device from the list and click [Connect].

3.

The “Store Preset” dialog will appear, as pictured below in
Figure 4-2.

4.

Type in a preset name of no more than fifteen characters.

5.

Type in a preset number, or accept the default.

6.

Type in a description (optional), which will help identify the
contents of the preset for further operations.

7.

Click [Store].

FIGURE 4-1: “Select Devices” Dialog

FIGURE 4-2: “Store Preset” Dialog
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Rename a Preset
After you have stored a preset in the device, you can change its name and description in Live Mode. You can also
change the name of a preset stored to PC in Design Mode.
To rename a preset stored to the device:
1.

Click on the [Live Mode] button on the control bar.

2.

Select the preset you wish to rename from the pull-down menu in the information box on the control bar.

3.

The main window will enter preview mode for the selected preset.

4.

Click the [Load] button on the control bar to make it the live preset.

5.

Click once anywhere in the information box.

6.

The “Preset Information” dialog will appear, as pictured to the right in
Figure 4-3.

7.

Type in the new name and/or description.

8.

Click [OK].

FIGURE 4-3: “Preset Information”
Dialog

To rename a preset stored to PC:
1.

Go to Design Mode.

2.

Open the preset file.

3.

Click once anywhere in the information box.

4.

The “Preset Information” dialog will appear, as above.

5.

Type in the new name and/or description.

6.

Click [OK].

7.

Resave the preset to PC.

Delete a Preset
The current live preset will not be available for deletion.
If you need to delete this preset, you must first select a
different live preset.
To delete a preset:
1.

Click on the [Design Mode] button on the
control bar.

2.

Select [File>Delete Preset].

3.

If the “Select Devices” dialog appears, select from
the list of available devices and click [Connect].

4.

The “Select Preset to delete” dialog will appear, as
pictured in Figure 4-4.

5.

Select the preset you wish to delete, or
Shift + Click to select multiple presets.

6.

Click [Delete].

FIGURE 4-4: “Select Preset to delete” Dialog
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Device Backup
You can backup all presets and settings stored in the device to a single archive, and restore this backup set to the device
at a later date. You must be in Design Mode to restore a backup.
To backup all presets in the device:
1.

Select [File>Backup Device] from the main menu.

2.

If the “Select Devices” dialog appears, select from the list of
available devices and click [Connect].

3.

The “Save As Backup” dialog appears, as pictured on the
right in Figure 4-5.

4.

Click [Backup Entire Device].

5.

The “Save Backup As” dialog appears, as pictured below
on the right in Figure 4-6.

6.

Navigate to the correct directory and type in a file name.

7.

Click [Save].

To backup specific presets:
1.

Follow steps 1-3 as above.

2.

Click to select a preset in the list. Shift + Click or
Ctrl + Click to select multiple presets.

3.

Click the [Backup Selected Presets] button.

4.

The “Save As” dialog appears.

5.

Navigate to the desired directory, name the file and
click [Save].

6.

Follow steps 4 and 5 for each preset you have selected to
back up.

FIGURE 4-5: “Save As Backup” Dialog

To restore a backup to the device:
1.

Click on the [Design Mode] button on the control bar.

2.

Select [File>Restore Device] from the main menu.

3.

The “Open Backup” dialog will appear, similar to the “Save
Backup As” dialog pictured on the right in Figure 4-6.

4.

Navigate to the correct directory and select the appropriate
backup set from the list.

5.

Click [Open].

6.

If the “Select Devices” dialog appears, select from the list of
available devices and click [Connect].

7.

The backup is sent to the device.
FIGURE 4-6: “Save Backup As” Dialog
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The Devices Menu
Shure Link Application List
This lists all the Shure Link software installed on your computer. To switch to another application, simply select it
from the menu and the application will launch in Design Mode.

Global Preset Mode
When Global Preset Mode is enabled on each Shure Link device on the network, a preset change on one device will
change presets on all of them. A check mark appears next to this menu command when it is active for the DFR22.

Control Pin Configuration
Select this menu option to configure the control pins for device control with external hardware. It opens the “Control
Pins” window, which is explained in detail in the chapter beginning on page 87.

Select COM port
Select this menu option to specify the COM port to which the DFR22 or Shure
Link network is connected. It opens the “COM Port” dialog, which lists all the
COM ports on your computer.
To select the COM port
1.

Select [Devices>Select COM Port] from the main menu.

2.

The “COM Port” dialog opens, as pictured in Figure 4-7.

3.

Choose the COM port to which the RS-232 cable is connected
and click [OK].

FIGURE 4-7: “COM Port” Dialog

Name Device
This menu option enables you to specify a unique name for the DFR22 to further
distinguish it in the device list.
To name the device:
1.

Select [Devices>Name Device] from the main menu.

2.

The “Name Device” dialog appears, as pictured in Figure 4-8.

3.

Enter a device name up to fifteen characters long and click [Name].

4.

The device name appears on the title bar of the main window when you are
in Live Mode, and is listed in the [Devices] menu.

FIGURE 4-8: “Name Device” Dialog

Device List
When you are in Live Mode this lists all Shure Link devices connected to the network. Select a device to access it
directly and launch its control software in Live Mode.
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Processor Features

SECTION 5

This section describes software features that are common among many of the processor parameter windows. For features specific to the individual processors, refer to the Fixed Processors section on page 40 and the Modular Processors section on
page 46.

Faders
Faders appear in many of the processor windows, as in the example pictured in Figure 5-1, below on the right. They allow
you to adjust gain with an up-down movement of the mouse, just as you would slide a fader on an actual mixer console.
You can also specify the level numerically by typing a number in the value box. First select the fader, then adjust the level
using any of the methods described below.

Selecting
Select a fader by positioning the mouse cursor over the fader knob and clicking on it with the left mouse button, or
by clicking in the value box located below the fader strip. The fader knob will highlight to indicate that it has been
selected. If the window contains multiple faders, you can move between them from left to right using the Tab key,
and move backward from right to left using Shift + Tab.
Fader knob in selection
Fader knob deselected
1

Adjusting the Level

1.

Fader Strip

2.

Fader Knob

Click on the fader strip at the level that you wish to set.

3.

Value Box

Right-click on the fader knob to set the level to 0 dB.

4.

Spin Buttons

To adjust the level with the mouse:

•
•
•

Click and hold on the fader knob to drag it up and down.

2

To adjust the level with a single keystroke:
1.

Select the fader you want to adjust.

2.

Use any of the following keys to adjust the value.
Keystroke

Result

Up Arrow

Increase 0.5 dB

Down Arrow

Decrease 0.5 dB

Page Up

Increase 3 dB

Page Down

Decrease 3 dB

Spacebar

Sets value to 0 dB

3

4
FIGURE 5-1: Standard Controls

Value Box
The value box allows you to specify the level within a tenth of a decibel. All faders have a value box associated
with them. In most processor windows, each fader has a value box located directly below it. The two exceptions are the GEQ10 and GEQ30 windows, which have only one gain value box for the entire set of faders. In
this instance, first select the knob you with to adjust, then enter a value in the box.
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Saving and Recalling Settings

Spin Buttons
Spin buttons appear next to all value boxes. They provide a convenient way to increment the setting without
having to type in a specific value.
To set the value with spin buttons:

•
•

Click on the up or down spin button to increment the level +/– 0.5 dB.
Click and hold on a spin button to scroll the level up or down. As you hold longer, the scrolling
will accelerate.

Saving and Recalling Settings
The settings in any processor parameter window can be saved to a computer file and recalled the next time you need a
similar setup in the same type of processor. This allows you to create custom or installation-specific default settings for
commonly used processors. If you are going to save many settings to PC, it is a good idea to create a directory specifically
for processor settings, or for a specific installation.
To save processor settings:
1.

Double-click the processor block to open its processor parameter window.

2.

Select [File>Save Settings] from the menu or press Ctrl + S on the keyboard.

3.

Navigate to the appropriate directory and type in a file name.

4.

Click [Save].

5.

The application will add a file extension that indicates the type of processor that created it. Refer to Appendix
C: File Extensions for a complete list of processor settings file extensions.

To recall processor settings:
1.

Double-click on the processor block to open its processor parameter window.

2.

Select [File>Recall Settings] from the menu or press Ctrl + R on the keyboard.

3.

Navigate to the appropriate directory and select the settings file.

4.

Click [Open].
Note:

You can only recall settings to the identical type of processor that created the settings file.

Naming Processor Windows
The parameter window for each modular processor block in the signal flow diagram can be given a unique name, which is
useful when multiple windows are open simultaneously. The default processor window titles include the name of the general processor type, the label of the channel strip on which they are placed, the slot number and the security lock status.
To distinguish between similar processors; you can customize the window name to reflect the particular function or settings
of the processor. The new window name will appear both in the title bar of the processor parameter window and on the
Windows task bar when the parameter window is minimized.
To rename a processor parameter window:
1.

Double-click the block to open its processor parameter window.

2.

Select [Options>Name] from the menu.

3.

Type the new name, up to fifteen characters.

4.

Click [OK].
Note:

This will change the name of the processor parameter window only. The title of the processor block does not change in the signal flow diagram.
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Snapshots
The snapshot feature is available in any processor parameter window that has a response curve or transfer curve graph.
It allows you to capture an image of the current curve, then display it for reference purposes as you revise the processor
settings. The processor remembers this snapshot until you take a new one in the same processor window, or quit the
application.
The following response curve examples are taken from the parameter window of a five-band parametric EQ with cut and
shelf filters (PEQ5+CS).
To use the snapshot feature:
1.

Click the [TAKE] button as shown in Figure 5-2. This captures the current response or transfer curve.

2.

Click the [SHOW] button. This displays the snapshot
behind the current curve. The button appears lighted in
green when the snapshot is displayed.

3.

Change the processor settings. As you
reshape the curve, you will be able to compare
it to the snapshot of the previous curve showing in the background, as illustrated in
Figure 5-3.

4.

Click the [SHOW] button again to toggle the
snapshot off and on, as pictured on the right in
Figure 5-4.
Note:

FIGURE 5-2: Taking a Snapshot

FIGURE 5-3: Reshaping the Response Curve

When you show the snapshot before you
have changed any processor settings, it will
be hidden behind the current curve. The
snapshot will show up as soon as you
reshape the curve with different settings.

FIGURE 5-4: Hiding the Snapshot
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Importing ASCII Files

Importing ASCII Files
EQ processor windows and the combined response window can display data contained in an ASCII file, as shown in the
following illustration of a “PEQ10+CS” window.

FIGURE 5-5: ASCII File Import

Use the ASCII file import feature to display frequency vs. magnitude information measured in Smaart or TEF. By inverting
the data, you can use the display as a visual guide when setting EQ parameters. The display only shows amplitude values
for frequencies contained in the file; it does not interpolate a line between actual measured points. Consequently, there
may be empty space in the display, particularly at low frequencies.
The ASCII import feature is compatible with the following formats:

•
•

Transfer function measurements in SIA-Smaart® Pro (versions 2/x and 3.x), and SIA SmaartLive™.
TDS measurements in all versions of TEF™ TDS software for Windows and DOS, and EFC measurements in
TEF SLX software.

Saving Files in ASCII Format
Smaart Files
To export a measurement using Smaart software, measure in Transfer Function Mode. Then select
[File>ASCII Save] from the Smaart application menu.
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TEF Files
To export a measurement using TEF TDS software:
1.Select
2.Enter
3.In

[File>Save] from the TEF TDS application menu.

file information, and click [Save].

the “Save TDS File” window, select “ASCII” as the file type.

Import Controls and Features
Import
Click this button to import ASCII files from either Smaart or TEF. When the “Open File” window
appears, select the file you wish to import. The data from the imported file will be displayed in the
Response Graph. When a TEF TDS or EFC file is imported, the average magnitude value is plotted at 0 dB
and all other magnitude values are biased accordingly. By default, Smaart transfer function files are not offset.
Magnitudes are centered around the 0 dB axis, just as they are in Smaart.

Refresh
Click this button to re-import the last imported file. If you take a new measurement in Smaart or TEF
and save it with the same file name, overwriting the previous file, you can click the [REFRESH] button
to import the new measurement without having to go through the open file dialog.
Note:

The [REFRESH] button DOES NOT change the bias of the original file. If the average magnitude
value of a TEF TDS or EFC file changes, the refreshed display will still be biased around the original
average value. Also, any offset you add to the file using the [OFFSET] text box will not change when
you click on [REFRESH].

Show
Click on this button to show or hide the imported file display. The [SHOW] button is lighted in green
when a file is displayed.

Offset
This indicates the amount by which the display is offset from the actual amplitude values contained
in the ASCII file. By default, a TEF TDS or EFC measurement will be offset by its average amplitude
to center it around the 0 dB axis in the Response Graph.

Invert
Click on this box to invert the displayed data around the x-axis. You may then use the inverted display as a visual guide for EQ parameters. [INVERT] is selected by default.

Help
Click on this button to access on-line help with importing Smaart and TEF ASCII files.
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Combined Response Graph

Combined Response Graph
This window sums the response curves of processors in the selected signal path to better assist you in achieving an even
room equalization. Access this window by selecting [View>Combined Response Graph] from the main menu.
1

2

3

4

5

7

6

FIGURE 5-6: “Combined Response Graph” Window

Window Features
1) Input Strip Selector
Your input strips are listed here, named as they are in the signal flow diagram. Select the strip for which you
would like to view the combined response.

2) Output Strip Selector
Your output strips are listed here, named as they are in the signal flow diagram. When you select both an input
strip and an output strip, the combined response is displayed for that signal path.

3) Processor Selector
By default, the response of equalizers, DFRs and crossovers are combined in the response graph. Equalizers
include PEQs, GEQs and CUT/SHELF processors. Crossovers include the 2-way crossover and the subwoofer processor. DFRs include all mono and stereo DFR processors.
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4) Snapshot
This feature allows you to freeze an image of the current combined response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW] button
appears lighted in green when the snapshot is displayed. For a more in-depth description of the snapshot feature, see the Snapshots section on page 35.

5) ASCII File Import
This feature allows you to import frequency data from SIA Smaart and Gold Line TEF into the response graph.
Once in the graph, you can use the graphical data for reference as you shape the response curve of any of the
processors in the signal path. See page 36 for instructions on how to use ASCII import.

6) Response Graph
This display will update as you make changes to processor settings and processor positions in the specified
signal path.

7) Polarity Indicator
The polarity displayed is for the sum total of the signal path. If an input is selected, this reflects the setting in
the Input Gain block. If an output is selected, the indicator reflects settings in the Matrix Mixer block, any crossover or subwoofer processor and the Output Gain block. If an input and output are both selected, all polarity
adjustments in the path are included.
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SECTION 6

Fixed Processors

These processors make up the three different stages of the DFR22's Gain Structure (see page 17 for more on this topic). They
are referred to as fixed processors because the gain and mix blocks in the signal flow diagram cannot be moved or deleted.

Input Gain
The “Input Gain” window contains individual controls for both input channels. Double-click on the gain block at the left end
of either input channel strip to open this window, as pictured below in Figure 6-1.

1
2

3

4
5
6
FIGURE 6-1: “Input Gain” Window

1) Scaling Options
Use these buttons to scale each input channel to match the output level of the equipment in line before the
Audio Processor. Click to toggle between -10dBV or +4dBu levels. The default setting is +4dBu.

+4dBu selected
–10dBV selected

2) Signal Polarity
Click this button to invert the polarity of the signal entering the input channel strip. The default setting is
normal polarity.

Normal polarity
Inverted polarity
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3) Gain Controls
Use these controls to adjust the signal level of each input channel. First select the fader knob, then adjust the
level with the mouse, arrow keys, or specify a level in the value box. For complete instructions on their operation, see the Faders section on page 33. The adjustment range is from +10dB to –infinity dB, and the default
setting is 0dB, or unity gain.
Note:

The input gain controls adjust the level of the signal after it has already been digitally converted
within the Audio Processor. Signal levels exceeding the input threshold of the Audio Processor
must be adjusted externally.

4) Channel Mute
Click this button to mute the channel. When mute is active, the button appears lighted in red. The default setting is inactive.

Mute activated
Mute inactive

5) Channel Label
Use this text box to customize the input channel strip label in the signal flow diagram. The default setting is
“Untitled In” for each input channel.

6) Link Indicator
This displays the link status of the input channel. Any setting you change on a linked channel will be changed
for the other channel in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Channel Linked
Channel not linked
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Matrix Mixer
The “Matrix Mixer” window contains controls for mix point connections in the signal flow diagram, organized under separate
window tabs for each output mix point. Double-click on either mix block to open this window, as pictured below in Figure 6-2.
1

2
3

4

5
6
7
FIGURE 6-2: “Matrix Mixer” Window

1) Window Tabs
The window opens focused on the output pane
for the mix block that you double-clicked. Click
on either tab to access controls for the other
output mix point.
The window tabs correspond to the output mix
points in the signal flow diagram. If you are
using a crossover or splitter, the tab title will
reflect that the processor spans both output
channels, as shown in Figure 6-3.

FIGURE 6-3: Crossover in “Matrix Mixer” Window
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2) Input Selector
Click this button to activate a connection from the corresponding input channel mix point in the signal flow diagram. The button appears lighted in green when a connection is activate. Controls for inactive inputs appear
faded out. The default setting is inactive.

Connection activate
Connection inactive

3) Signal Polarity
Normal polarity
Inverted polarity

Click this button to invert the polarity of the signal entering the matrix
mixer point. The default setting is normal polarity.

4) Gain Controls
Use these controls to adjust the signal level of each channel. First select the fader knob, then adjust the level
with the mouse, arrow keys, or specify a level in the value box. For complete instructions on their operation,
see the Faders section on page 33. The adjustment range is from +10dB to –infinity dB, and the default setting
is 0dB, or unity gain.

5) Channel Mute
Mute activated
Mute inactive

Click this button to mute the channel. When mute is active, the button
appears lighted in red. The default setting is inactive.

6) Channel Label
This displays the channel label, which you specify in the “Input Gain” or “Output Gain” window.

7) Link Indicator
This displays the link status of the matrix mixer point. When you link mix blocks, you are linking all of the controls for each mix block except for the input selector. For a complete explanation of linking and link groups, see
the Linking section on page 24.
Processor Linked
Processor Not Linked
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Output Gain

Output Gain
The “Output Gain” window contains individual controls for both output channels. Double-click on the gain block at
the right end of either output channel strip to open this window, as pictured below in Figure 6-4.

1
2

3

4
5
6
7

FIGURE 6-4: “Output Gain” Window

1) Scaling Options
Use these buttons to scale each output channel to match the output level of the equipment in line after the
Audio Processor. Click to toggle between -10dBV or +4dBu levels. The default setting is +4dBu.

+4dBu selected
–10dBV selected

2) Signal Polarity
Click this button to invert the polarity of the signal exiting the output channel strip. The default setting is
normal polarity.

Normal polarity
Inverted polarity
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3) Gain Controls
Use these controls to adjust the signal level of each output channel. First select the fader knob, then adjust the
level with the mouse, arrow keys, or specify a level in the value box. For complete instructions on their operation, see the Faders section on page 33. The adjustment range is from +10dB to –infinity dB, and the default
setting is 0dB, or unity gain.

4) Output Pads
Click one of these buttons to attenuate the signal output by –12dB or –18dB. Each button appears lighted in
red when the selected pad is activated. The default status of these buttons is inactive.
12dB Pad activate
12dB Pad inactive

Note:

You cannot activate the –12dB or –18dB pads simultaneously on the same output.

5) Channel Mute
Click this button to mute the channel. When mute is active, the button appears lighted in red. The default setting is inactive.
Mute activate
Mute inactive

6) Channel Label
Use this text box to customize the output channel strip label in the signal flow diagram. The default setting is
“Untitled Out” for each output channel.

7) Link Indicator
This displays the link status of the output channel. Any setting you change on a linked channel will be changed
for all other channels in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Channel Linked
Channel not linked
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Modular Processors

SECTION 7

This section describes the features and controls specific to each of the processor block parameter windows. In some
cases, several processor blocks share nearly identical controls, such as the downward expander and gate. In these
instances, the processors are described as a group, using a single parameter window as the illustrated example. Control
settings that are individual to one of the processors in the group are so noted in the description of those controls.

Automatic Gain Control (AGC)
The AGC creates a more consistent volume level when talkers speak at different volume levels. It acts like a sound engineer with his or her finger on a fader, increasing the gain of the input signal when the level is too low, and decreasing it
when the level is too high.
Block Name

Description

AGC

Automatic Gain Control
3

4

5

6

2

1

8

7
FIGURE 7-1: AGC Window

Function
Use this processor in situations where it is desirable to maintain a constant volume level, such as for podium and
lectern microphones where the talkers’ proximity to the microphone varies. The AGC compensates for quiet levels
by gradually raising the gain. If a talker then speaks loudly into the microphone, the AGC will gradually reduce the
gain. However, if an individual talker quickly changes the level of his or her voice by shouting, whispering, or getting very close to the microphone, that brief peak or valley in the overall level will pass through the AGC
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Automatic Gain Control (AGC)

unchanged. The AGC only changes gain when it detects activity on its input. This prevents undesirable gain
changes during pauses in program material.

Parameter Window Features
This section describes the features and parameter controls specific to the Automatic Gain Control processor, as
pictured above in Figure 7-1.

1) Maximum Gain Line
The greatest amount that the AGC will boost the signal is +12dB, as indicated by the maximum gain line. This
prevents undesirable noise modulation or acoustic feedback problems that may arise from excessively boosting low-level signals. The maximum gain line only appears in the transfer curve graph when the combination of
the threshold, hinge, and ratio settings result in the AGC imposing the +12dB limit.

2) Transfer Curve Graph
The transfer curve graph displays the threshold level and compression ratio settings as graphical elements that
you can position with the mouse. The resulting transfer curve represents the change in the signal output level.

3) Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. You can drag this slider
with the mouse, left and right along the top edge of the transfer curve graph, to change the threshold setting.

4) Ratio Slider
The position of the ratio slider corresponds to the setting in the ratio control. You can drag this slider with the
mouse, up and down along the right-hand edge of the transfer curve graph, to change the ratio setting.

5) Gain Reduction Meter
This meter indicates the total gain boost or reduction you are achieving on the input signal with the current processor settings. This feature can be toggled off and on by selecting the [Options>Gain Reduction Meter] menu
option. Its default status is on.

6) Gain Controls
Use the gain controls to adjust the input and output gain levels. The range of available gain values is between
-12dB and +12dB in 0.5dB increments, with 0dB as the default value. You can change the value using the conventions explained in the Faders section on page 33.

7) Hinge Slider
The position of the hinge slider corresponds to the setting in the hinge control. You can drag this slider with the
mouse, left and right along the bottom edge of the transfer curve graph, to change the hinge setting.

8) Transfer Curve Meter
When you are in Live Mode, this meter depicts the signal's input level and relative output level, so you can
monitor the processor's effect on the current program material. This feature can be toggled off and on by
selecting the [Options>Transfer Curve Meter] menu option. Its default status is on.
Note:

You may experience reduced software performance if you have a large number of meters active overall in the Audio Processor software. You can selectively turn off either the transfer curve meter or the
gain reduction meter, or both, from the [Options] menu.
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Threshold Exceeded Indicator.
Signal level has exceeded the threshold
Signal level has not reached the threshold

This indicator appears lighted in yellow when the
input signal to the processor block exceeds the
specified threshold

Threshold
This indicates the level the signal gain must reach before the processor increases it. Signal levels below the threshold are passed through the processor at unity gain. You can change the
value by clicking on the spin buttons, typing in a specific value, or using the threshold slider
above the transfer curve graph. The available range of values is from -60dB to +20dB in 0.5dB
increments, with a default value of 0dB.

Ratio
This indicates the amount of gain reduction you are achieving at the output of the processor, relative to the input level that exceeds the hinge. A setting of 4:1, for example, means that a 4dB
increase in the level of the program material results in a 1dB increase in the output level from
the processor. You can change the value by clicking on the spin buttons, typing in a specific value, or using the
ratio slider on the right-hand side of the transfer curve graph. The range of available values is from 1:1 to 10:1,
in increments of a tenth, with a default value of 2:1.

Attack
This indicates how much time the processor waits before responding to rising or falling input levels, once the input level exceeds the threshold, The available values are from 0.2s to 3s, with a
default value of 2 seconds.

Decay
This indicates how much time the processor waits before returning to unity gain, once the input
level increases or decreases closer to the hinge setting. The range of available values is from
0.5s to 5s, with a default value of 5 seconds.

Hinge
The hinge setting is the target output level of the AGC. It is a pivot point that determines
whether the input level is raised or lowered. Signal levels below the hinge (but above the
threshold) will be raised and levels above the hinge will be lowered. You can change the value
by clicking on the spin buttons, typing in a specific value, or using the hinge slider below the
transfer curve graph. The available range of values is from -60dB to +20dB in 0.5dB increments, with a default
value of 0dB.

Default
Click this button to reset the processor to its system default settings.
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Bypass
Click to pass signal through without altering it. When bypass is active, the button appears lighted in red. The
default setting is inactive.
Bypass active
Bypass inactive

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW]
button appears lighted in green when the snapshot is displayed. For a more in-depth description of
the snapshot feature, see the Snapshots section on page 35.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked
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Compressor/Limiter
Compressors and limiters reduce the output level of the signal relative to the input level, once the input level exceeds a certain threshold. The Audio Processor provides the following types of compressors and limiters:
Block Name

Description

COMP

Compressor

Sft COMP

Soft Knee Compressor

LIM

Limiter

Sft LIM

Soft Knee Limiter

ST COMP
Sft ST COMP
ST LIM

Same as above: for use on two
channels that are a stereo pair.

Sft ST LIM
PEAK LIM

Peak Stop (look ahead) Limiter

2

4

3

5

1

7

6

FIGURE 7-2: Sft ST COMP Window

Function
Use the compressor to scale the output of a signal so it is suitable for equipment with a narrower dynamic range,
such as an amplifier, tape deck, or loudspeaker. Use the limiter to protect the system against sudden bursts of
loudness that could potentially damage loudspeakers. By delaying the signal 1 ms, the Peak Stop Limiter has an
attack time of 0 to provide even more control over transient sounds. The compressor and limiter function similarly,
however the limiter is typically set for a faster attack time and a higher compression ratio.
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The following types of processors are available in both limiters and compressors:

•

Soft Knee - These processors provide a gradual transition from uncompressed signal to compressed signal.
They consume a higher percentage of total DSP than those without the soft knee option.

•

Stereo - These processors allow you to preserve a stereo image by placing two blocks that function as a single
processor on two different channels. Both processor channels react with identical gain reduction when the
input to either channel exceeds the threshold setting. These processors consume a higher percentage of total
DSP than mono processors.

Parameter Window Features
This section explains the features and parameter controls of compressors and limiters using the Sft ST COMP as
the example, as pictured in Figure 7-2 above. All the processors covered in this section are very similar in operation. Any differences between their features and functionality are noted where applicable.

1) Transfer Curve Graph
The transfer curve graph displays the threshold level and compression ratio settings as graphical elements that
you can position with the mouse. The resulting transfer curve represents the change in the signal output level.

2) Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. You can drag this slider
with the mouse, left and right along the top edge of the transfer curve graph, to change the threshold setting.

3) Ratio Slider
The position of the ratio slider corresponds to the setting in the ratio control. You can drag this slider with the
mouse, up and down along the right-hand edge of the transfer curve graph, to change the ratio setting.

4) Gain Reduction Meter
This meter indicates the total gain increase or reduction you are achieving on the input signal with the current
processor settings. This feature can be toggled off and on by selecting the [Options>Gain Reduction Meter]
menu option. Its default status is on.

5) Gain Controls
Use the gain controls to adjust the input and output gain levels. The range of available gain values is between
-12dB and +12dB in 0.5dB increments, with 0dB as the default value. You can change the value using the conventions explained in the Faders section on page 33.

6) Transfer Curve Meter Selectors (Stereo Processors Only)
These buttons allow you to select the channel or channels for which you would like to view transfer curve
metering. Each button appears lighted in green when the meter is active for that channel.

7) Transfer Curve Meter
When you are in Live Mode, this meter depicts the signal's input level and relative output level, so you can
monitor the processor's effect on the current program material. This feature can be toggled off and on by
selecting the [Options>Transfer Curve Meter] menu option. Its default status is on.
Note:

You may experience reduced software performance if you have a large number of meters
active overall in the DFR22 software. You can selectively turn off either the transfer curve
meter or the gain reduction meter, or both, from the [Options] menu.
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Threshold Exceeded Indicator
Signal level has exceeded the threshold
Signal level has not reached the threshold

This indicator appears lighted in yellow when the
input signal to the processor block exceeds the
specified threshold

Threshold
This indicates the gain level the signal must reach before the processor begins compressing it.
You can change the value by clicking on the spin buttons, typing in a specific value, or using
the threshold slider above the transfer curve graph. The available range of values is from -60dB
to +20dB in 0.5dB increments, with a default value of 0dB.

Ratio
This indicates the amount of gain reduction you are achieving at the output of the processor, relative to the input level. A setting of 4:1, for example, means that a 4dB increase in the level of
the program material results in a 1dB increase in the output level from the processor. You can
change the value by clicking on the spin buttons, typing in a specific value, or using the ratio slider on the righthand side of the transfer curve graph. The range of available values is from 1:1 to INF:1, in increments of a
tenth, with a default value of 2:1 for the compressors and 10:1 for the limiters. The Peak Stop Limiter has a
fixed ratio of INF:1.

Attack
This indicates how much time the processor waits before starting to reduce the gain, once the
input signal level passes the threshold. The range of available values is from 1ms to 200ms,
with a default value of 5ms for the compressors and 2ms for the limiters. The Peak Stop Limiter
has a fixed attack time of 0 ms.

Decay
This indicates how much time the processor waits before returning to unity gain, once the input
signal level drops below the threshold. The range of available values is from 50ms to 1000ms,
with a default value of 100ms for the compressors, 50ms for the limiters, and 20ms for the Peak
Stop Limiter.

Knee
In soft knee processors, this control displays a pull-down list from which you can select either soft knee or hard
knee compression. The default setting is “SOFT.” In the standard compressors and limiters, this control is disabled.
Soft Knee
Processor

Select “SOFT” or “HARD” from the pull-down list.

Standard
Processor

The control is disabled.

Default
Click this button to reset the processor to its system default settings.
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Bypass
Bypass active
Bypass inactive

Note:

Click to pass signal through without altering it. When bypass
is active, the button appears lighted in red. The default setting is inactive.

When bypass is active in the Peak Stop Limiter, the 1 ms of delay is not bypassed

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW]
button appears lighted in green when the snapshot is displayed. For a more in-depth description of
the snapshot feature, see the Snapshots section on page 35.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked

Soft Knee Processors
The following examples illustrate the difference between the hard knee and soft knee compression settings. All
other settings in these examples remain identical.
A soft knee setting, pictured in Figure 7-3, is useful when
you are working with high compression ratios. The soft
knee gradually increases the compression ratio from 1:1,
at approximately 12dB below the threshold, up to the
specified ratio, at approximately 20dB above the threshold. This gradual increase in ratio makes the compression
less obtrusive than with the hard knee.

FIGURE 7-3: Soft Knee Option

Note:

The hard knee setting, pictured in Figure 7-4, immediately
activates compression at the ratio you have specified,
once the signal level exceeds the threshold. This setting
is especially useful in a limiter, because it will keep sudden peaks from exceeding the threshold without affecting
signal below the threshold.

FIGURE 7-4: Hard Knee Option

If the situation calls for a hard knee setting, you can conserve DSP by using a
standard processor instead of a soft knee processor.
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Stereo Processors
The stereo processors have the same features and functionality as their mono counterparts, and include some
additional features.

•
•

Changes to settings of either of the two processor channels will be applied to the other channel as well.

•
•

Dual transfer curve meters display the channel A input level in red and the channel B input level in blue.

•

There is a threshold exceeded indicator for both the A and B channels.

Both processor channels react with identical gain reduction when the input to either channel exceeds the
threshold setting.
Meter selectors allow you to alternately view the transfer curve meter for channel A, channel B, both channels,
or neither.
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Crossover/Splitter/Subwoofer
The crossover divides the frequency spectrum of the input signal into multiple bands, then outputs each band to a separate
channel. The splitter distributes the input signal across two outputs without any further processing. The subwoofer is a single low pass filter. Because it is fully configurable, it can also be used as a bandpass or high pass filter.
Block Name

Description

XOVER 2

2-way Crossover

SPLIT 2

2-way Splitter

SUB

Subwoofer

4

5

6

7

3

2

1

FIGURE 7-5: XOVER2 Window

Function
Use the crossover to divide the frequency range of the input signal with two filters, then distribute each frequency
band to a separate output for different types of speakers. Use the splitter when you need to simply distribute the
same signal to both outputs. Use the subwoofer to isolate a single frequency band before sending the signal to an
output. The crossover, splitter and subwoofer are for output processing only, and cannot be placed on input channel strips. See the Adding Processors: The Crossover, Splitter, and Subwoofer section on page 23 for more information on placing these processors in the signal flow diagram
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Parameter Window Features
This section explains the features and parameter controls of the crossover and subwoofer using the XOVER 2 as
the example, as pictured above in Figure 7-5. The features of the subwoofer are identical, aside from the number
of the pass band filters. The splitter has no parameter window, as it performs no processing of the signal; it simply
routes it.

1) Pass Band Controls
There is a set of controls for each output channel associated with the pass bands.

2) Output Channel Labels
These labels at the head of the columns of pass band controls are color-coded to match the corresponding
band pass curves in the response plotter. They indicate to which output channel each pass band is routed.

3) Response Plotter
This area of the window graphically displays the pass band filters and crossover points, which you can manipulate by clicking and dragging with the mouse.
Note:

To view the effect of the crossover on the signal path, select [View>Combined Response Curve] from the
main menu. For more information, refer to the Combined Response Graph section on page 38.

4) Pass Bands
Each band has a corner handle on either side that you can drag left and right to independently adjust the upper
and lower corner frequencies. There is also a gain handle in the center of each band that you can drag up and
down to adjust the output level of the pass band. When you select a handle, it fills with a colored ball to indicate
that it is the active control. The upper and lower filter slopes are set with the pass band controls in the lower
section of the window.

5) Gain Handle
Drag this handle up or down to set the gain of the pass band. The position of this handle corresponds to the
setting in the [GAIN] control.

6) Crossover Handle
This handle indicates the frequency of the crossover point between two pass bands. You can drag it left and
right to simultaneously adjust the corner frequencies of the intersecting filter slopes. When you select a crossover handle, it turns green to indicate that it is the active control, and the corresponding corner handles fill to
indicate they are selected. The corner handles maintain their positions relative to each other as you slide the
crossover handle.

7) Corner Handles
Drag these handles left or right to set the corner frequencies of the pass band. The position of these handles
correspond to the settings in the [LOW CORNER FREQ] and [UPPER CORNER FREQ] controls.
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Set and Show Gains/Normalize Plot
Toggle between these two buttons to alternately display the pass bands at
their actual gain levels, and display them normalized. The default setting is
[SET AND SHOW GAINS ON PLOT].
When the gain levels of pass bands are significantly different, the crossover point appears offset from its actual location, as illustrated in Figure 76. Use the normalize plot display mode when you need to see the precise
location of the crossover point, as illustrated in Figure 7-7.
FIGURE 7-6: [SET AND SHOW GAINS
ON PLOT]

•

Click the [SET AND SHOW GAINS ON PLOT] button to display and
adjust pass band gain levels. With this setting, filter levels are
reflected in the response plotter and the gain handles are visible
on the pass bands.

•

Click the [NORMALIZE PLOT] button to display the pass bands at
unity gain in the response plotter. Actual gain settings are not
affected by this setting.

Default

FIGURE 7-7: [NORMALIZE PLOT}

Click this button to reset the processor to its system default
settings.

Mute
Mute active
Mute inactive

Click this button to mute the output of its corresponding band.
When mute is active, the button appears lighted in red The default
setting is inactive.

Polarity
Normal polarity
Inverse polarity

Click this button to invert the polarity of the signal leaving the
crossover. The default setting is normal polarity.

Low Corner Freq
This indicates the frequency setting of the lower corner of the pass band. The range of values
available depends on the setting of the upper corner frequency, as corner frequencies cannot
overlap. You can change the value by clicking on the spin buttons, using the keyboard controls,
or typing in a specific value. The default values for the pass bands are listed below.
Band 1

OUT

Band 2

2.0 kHz
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Low Filter Type/Upper Filter Type
This indicates the slope of the corresponding pass band corner. Select a value from the pulldown menu, as listed below. The default setting is 24dB/oct Linkwitz-Riley.
Abbreviation

Description

6 Butt

6dB/oct Butterworth

6 Bessel

6dB/oct Bessel

12 Butt

12dB/oct Butterworth

12 Bess

12dB/oct Bessel

12 L-R

12dB/oct Linkwitz-Riley

18 Butt

18dB/oct Butterworth

18 Bessel

18dB/oct Bessel

24 Butt

24dB/octButterworth

24 Bess

24 dB/octBessel

24 L-R

24 dB/octLinkwitz-Riley

Upper Corner Freq
This indicates the frequency setting of the upper corner of the pass band. The range of values
available depends on the setting of the lower corner frequency, as corner frequencies cannot
overlap. You can change the value by clicking on the spin buttons, using the keyboard controls,
or typing in a specific value. The default values for the pass bands are listed below.
Band 1

2.0 kHz

Band 2

OUT

Gain
Use the gain controls to adjust the output gain levels. The range of available gain values is
between -18dB and +12dB in 0.5dB increments, with 0dB as the default value. You can
change the value using the conventions explained in the Faders section on page 33.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked
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Keyboard Controls
You can use keyboard controls to make fine adjustments to the handle positions in the response plotter. Click
to select a handle, then use the following shortcuts.
Keystroke

Frequency Adjustment

¬

Decreases frequency by one screen pixel

®

Increases frequency by one screen pixel

Shift + ¬

Decreases frequency by 1/3 octave

Shift + ®

Increases frequency by 1/3 octave

Note:

Nudging the frequency by one screen pixel changes the value by approximately 1/100 of an
octave, or 1%.

Keystroke

Gain Adjustment


Increases gain by 0.5 dB

¯

Decreases gain by 0.5 dB

Shift + 
or Page Up
Shift + ¯
or Page Down
Spacebar or right
mouse click
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Cut and Shelf Filters
Cut and shelf filters boost or cut the overall high and low frequency characteristics of a system, and roll off the high and low
end of the frequency spectrum.
Block Name

Description

CUT/SHELF

High and Low Cut/High and Low and Shelf Filters

3

4

2

1
FIGURE 7-8: CUT/SHELF Window

Function
Use this processor when you need to combine cut filters with broad-spectrum high and low-end room equalization.
The high and low cut filters feature a wide variety of slope options, between -6dB/oct and -24dB/oct. You can also
specify the corner slope of the shelf filters, either 6dB/oct or 12dB/oct.

Parameter Window Features
This section describes the features and parameter controls specific to the Cut and Shelf processor, as pictured
above in Figure 7-8.
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1) Response Graph
This curve is a graphical representation of the combined results of the filter handles in the response plotter.
Note:

The curve does not reflect the accumulated effect of multiple processor blocks in the signal
path. To view a combined curve, select [View>Combined Response Curve] from the main
menu. For more information, refer to the Combined Response Graph section on page 38.

2) Response Plotter
This area of the parameter window graphically displays the cut and shelf filter handles, which you can manipulate by clicking and dragging with the mouse. When you initially open the parameter window, the filter handles
appear in their system default positions at the extreme high and low boundaries of the frequency spectrum.
Click on a handle to view its response curve and adjust settings.

3) Cut Filters
Cut filters appear as handles at the bottom edge of the response plotter, with dashed vertical lines extending
along their center frequencies. Their default frequency setting is “OUT,” and the default type is 6dB/Butterworth.

4) Shelf Filters
The high and low cut/shelf filters appear along a horizontal axis in the center of the response plotter. Their
default frequency setting is “OUT,” and the default type is 6dB/oct.

Frequency
This indicates the frequency of the selected filter point. You can change the value by clicking on the spin buttons, using keyboard controls, or by entering a specific value. The frequency range is from 25Hz to 20kHz, with “OUT” as the default setting.

Type
This indicates the slope type for the selected filter. The values available in the
pull-down menu vary for cut and shelf filters, as listed below.
Shelf

6 dB/Octave*
12 dB/Octave

Cut
6 dB/oct Butterworth*

18 dB/oct Butterworth

6 dB/oct Bessel

18 dB/oct Bessel

12 dB/oct Butterworth

24 dB/oct Butterworth

12 dB/oct Bessel

24 dB/oct Bessel

12 dB/oct Linkwitz-Riley

24 dB/oct Linkwitz/Riley

* Indicates default setting

Gain
This indicates the current gain setting of the selected shelf filter. The range of available
gain values is between -18dB and +18dB in 0.5dB increments, with 0dB as the default
value. You can change the value using the conventions explained in the Faders section on page 33. When you
are working with a cut filer this control is disabled and displays the word “CUT.”

Clear
Click this button to return filter settings to their defaults. It opens the “Clear” dialog (Figure 7-20
on page 85), which provides you with the option to clear all filter settings, or to clear only selected
filter settings.
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Bypass
Bypass active
Bypass inactive

Click to pass signal through without altering it. When bypass is
active, the button appears lighted in red. The default setting is
inactive.

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW]
button appears lighted in green when the snapshot is displayed. For a more in-depth description of
the snapshot feature, see the Snapshots section on page 35.

Importing ASCII Files
This feature allows you to import frequency data from SIA Smaart and Gold Line TEF into the
response graph. Once in the graph, you can use the graphical data for reference as you shape
the response curve of the processor. See page 36 for instructions on how to use ASCII import.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked

Fine Tuning Parameters
You can precisely adjust parameters for the selected filter using any of the following methods:

•
•
•

Enter a number into any of the parameter boxes
Using the spin buttons (or drop down box) next to the parameter boxes
Using the keyboard controls

Keyboard Controls
You can use the following keyboard controls to make fine adjustments to the currently selected filter.
Keystroke

Result
¬

Decreases frequency by one screen pixel

®

Increases frequency by one screen pixel



Increases gain by 0.5 dB

¯

Decreases gain by 0.5 dB

Shift + ¬

Decreases frequency by 1/3 octave

Shift + ®

Increases frequency by 1/3 octave

Shift + 
or Page Up
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Shift + ¯
or Page Down
Spacebar or right
mouse click
Delete
Note:

Decreases gain by 3 dB
Sets gain to 0 dB
Resets selected filter(s) to default settings

Nudging the frequency by one screen pixel changes the value by approximately 1/100
of an octave, or 1%

Copy and Paste
Filter handle settings can be copied and pasted between “Cut and Shelf” processor windows.
To copy and paste filters:
1.

Click to select a single filter, or select multiple filters using one of the following methods:

•
•

Ctrl + Click.
Use the [Edit>Select All] menu command.

2.

Select the [Edit>Copy] menu command.

3.

Open the “Cut and Shelf” processor window where you wish to paste filter settings.

4.

Select the [Edit>Paste] menu command.
Note:

When filters are part of a multiple selection, they are highlighted in pink and their parameter settings are locked. To de-select from a multiple selection, press the Esc key or
click on any control outside the selection area.
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Delay
The delay processor temporarily stores the signal in delay memory, then passes it on after the specified interval has
elapsed. The Audio Processor provides the following types of delay:
Block Name

Description

DLY5ms

5 Millisecond Maximum Delay

DLY150ms

150 Millisecond Maximum Delay

DLY500ms

500 Millisecond Maximum Delay

DLY2s

2 Second Maximum Delay

FIGURE 7-9: DLY 150ms Window

Function
Use delay to align the sound output from different speakers so that it arrives simultaneously at the audience members. You can also use delay to correct phase cancellation problems between installed loudspeakers. Delay can
be calculated with time, distance, and air temperature increments.
Note:

Each type of delay processor block will consume the maximum amount of delay memory indicated in the block name, regardless of how much you are actually using. In order to conserve
Audio Processor resources, you should select the delay processor with the nearest maximum to
your required delay time.

Parameter Window Features
This section explains the features of the delay processors using the DLY150 as the example, as pictured above in
Figure 7-9. The features of the other delays are identical, aside from the maximum delay time available.

Units
Use this control to specify whether parameters should be in English or Metric units.
The default setting is Metric.
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Time
Use this control to specify the delay in milliseconds. The range of values is between
0ms and the maximum delay time of the processor block, in this case 150ms. The
default value is 0ms.

Distance
Use this control to specify the delay by distance. The range of values varies,
depending on the maximum delay time, but the default is always zero. Select the
appropriate unit of measure with the radio buttons to the right of the control.
When English units are selected, you can choose between inches or feet. When Metric units are selected, distance is indicated in meters.

Air Temperature
Use this control when you are setting the delay by distance, since the speed of
sound is affected by air temperature. The range of values is from -13°F to
122°F, or -25°C to 50°C. When English units are selected, air temperature is
indicated in Fahrenheit. When Metric units are selected, air temperature is indicated in Celsius. The default
value is 69° Fahrenheit or 20° Celsius.

Bypass
Bypass active
Bypass inactive

Click to pass signal through without altering it. When bypass is
active, the button appears lighted in red. The default setting is
inactive.

Clear
Click this button to reset the processor to its system default settings.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked
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Digital Feedback Reducer (DFR)
The DFR uses Shure's patented Adaptive Notch Filter algorithm that can discriminate between feedback and non-feedback
sounds. It automatically detects feedback and deploys narrow-band notch filters at the feedback frequencies. No sound system (the combination of microphones, mixing, signal processing, power amplifiers and loudspeakers) has an absolutely flat
response. When the level of a sound system is increased, the frequencies at which peaks occur will be the first to exceed the
threshold of feedback. The DFR attenuates these frequencies, flattening the response of the sound system. Thus the system can then be operated at a higher overall level. The DFR22 Audio Processor provides the following types of DFR:
Block Name

Description

DFR5

5 Band Digital Feedback Reducer

DFR10

10 Band Digital Feedback Reducer

DFR16

16 Band Digital Feedback Reducer

ST DFR5
ST DFR10
ST DFR16

1

Same as above: for use on two
channels that are a stereo pair.

2
FIGURE 7-10: DFR10 Window

Function
Use the DFR as the initial processor on any input channel that receives signal from a live microphone where feedback is problematic. When the DFR detects feedback, it inserts a shallow, narrow filter into the audio path to
reduce gain at the feedback frequency. This filter is called a notch filter, due to the narrow section of the frequency
spectrum it affects. You can specify the width at which new filters deploy with the filter Q setting, which is accessed
from the DFR processor’s [Options] menu. For more information on filter notch width, refer to the High Q Filters
and Low Q Filters section on page 70
The stereo DFR deploys a notch filter to both channels at the same frequency and depth when feedback is
detected on either channel. In this way it preserves the stereo image.
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Parameter Window Features
This section explains the features and parameter controls of the digital feedback reducer using the DFR10 as the
example, as pictured above in Figure 7-10. The features of the other DFRs are identical, aside from the number of
notch filters available and stereo functionality.

1) Response Graph
This curve is a graphical representation of the combined results of the processor's active notch filters (highlighted in yellow).
Note:

The curve does not reflect the accumulated effect of multiple processor blocks in the signal path. To
view a combined curve, select [View>Combined Response Curve] from the main menu. For more
information, refer to the Combined Response Graph section on page 38.

2) Currently Selected Filter
This line appears in the response graph at the frequency of the currently selected filter, which is indicated
between the two red arrows in the row of feedback filters.

Frequency
This indicates the frequency of the selected filter. You can change the value by clicking on
the spin buttons, using keyboard controls, or by entering a specific value. The frequency
range is from 25Hz to 20kHz, with “OUT” as the default setting.

Depth
This indicates the gain reduction of the selected filter. The range of available gain values is
between 0db and -18dB in 0.5dB increments, with a default setting of 0dB.

Type
This indicates the bandwidth type of the selected filter. Select “HIGH Q” or “LOW Q” from the
pull-down menu. “HIGH Q” is the default value. See the High Q Filters and Low Q
Filters section on page 70 for more information.

Feedback Filters
The feedback filters controls appear as a row of LED-style indicators. You can specify the number of fixed versus dynamic filters by sliding the red brackets left and right
with the mouse. Active filters are indicated in yellow and appear in the Response
Graph. Refer to the Filter Allocation section on page 70 for further explanation.

Lock
Click this button to prevent both the deployment of new filters and the deepening of existing filters. Use this
option to keep the DFR from deploying filters for program material that contains desired feedback or sounds
closely resembling feedback (such as guitar effects, synthesized tones, flute or pipe organ). The button
appears lighted in red when the lock feature is active. The default setting is inactive.
Lock active
Lock inactive
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Bypass
Click to disengage DFR notch filtering. Bypass also locks the DFR, preventing deployment of new filters. When
bypass is active, the button appears lighted in red. The default setting is inactive.
Bypass active
Bypass inactive

Clear
Click this button to clear filter settings. It opens the “Clear” dialog (Figure 7-20 on page 85), which
provides you with the option to clear all filter settings, or to clear only selected filter settings.

Auto Clear
Click this button to open the “Auto Clear” dialog, as described on page 72. This feature allows you to specify if
and when the DFR should clear the dynamic filters that it has allocated, and remove changes to fixed filter
depth. The button appears lighted in green when this feature is active. The default setting is inactive.
Auto clear active
Auto clear inactive

Front Panel
Use this control to assign the DFR processor to the front panel LEDs and controls. When a
DFR is assigned to the front panel, active filters will light the LEDs on the row(s) you have
specified and the front panel buttons will control the processor. For a description of the front
panel buttons, refer to the Installation Guide. Only one DFR can be assigned to any given row of the front
panel. The default setting is “Unassigned.”
Processor

Settings
[Unassigned]

Mono DFR

[Row A]
[Row B]

Stereo DFR

Note:

[Unassigned]
[Rows A & B]

In the signal flow diagram, when you copy and paste a DFR block that is assigned to the front
panel, the new pasted block will not be assigned. When you cut and paste a DFR block that has
been assigned to the front panel, it remains assigned.

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW]
button appears lighted in green when the snapshot is displayed. For a more in-depth description of
the snapshot feature, see the Snapshots section on page 35.
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Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked

Basic DFR Setup
The DFR (or any other feedback reduction processor) will not enable you to increase system gain beyond the
physical limits of the sound system. In most cases, you reach a point of diminishing returns after five or eight notch
filters are set. This is because there are usually only a few dominant peaks in the response of the system. In most
cases, you can expect a 6 dB to 9 dB improvement in gain-before-feedback by using the DFR. When you are ringing out the system and notice that many frequencies feedback simultaneously, even when you increase the gain
very slowly, you have reached the point of diminishing returns. If at this point the system still has insufficient gain
before feedback, other changes must be made to the sound system, such as changing the placement of the microphones and/or loudspeakers.
There are two basic ways in which to set-up the DFR to reduce feedback; the Ring-Out Method and the Insurance
Policy Method, as described below.

•

Ring Out Method - With this method, you use the DFR as a preemptive measure against feedback for input
channels that operate near the feedback point and need an extra margin of stability. Using this method, you
raise the input channel's gain beyond its normal setting to deliberately make the system feed back. The DFR
will then set the proper filters. Then, when you reduce the input gain to an appropriate level, the system is stable and usable.

•

Insurance Policy Method - With this method, you use the DFR as added insurance against unexpected feedback in an otherwise stable system. Simply place the DFR processor in the signal path, without defining any settings. This method is used for systems which already have sufficient gain-before-feedback, but need protection
from occasional feedback occurrences due to non-stationary microphones or user-adjustable gain controls.

To ring out the system:
1.

Remove any active filters by clicking the [CLEAR] button.

2.

The “Clear” dialog opens.

3.

Select [Clear All Filters] and click [OK].

4.

Open all mics.

5.

Slowly raise the gain of the sound system while talking into the microphones until the first frequency begins to
feed back. The DFR processor will set a notch filter to attenuate this frequency.

6.

Once the system has stopped feeding back, you can continue by further raising the level and repeating the
process for additional frequencies. Typically you can raise the gain 3 dB to 9 dB above the level at which feedback first occurred.

7.

Allocate the deployed filters as “fixed” (see the following Filter Allocation section). The remaining dynamic filters will deploy as needed when the system is in use.
Note:

You can copy the fixed filters to a PEQ block to allow for more dynamic filters in the DFR window.
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Filter Allocation
By default, half of the DFR processor filters are allocated as fixed, and half are dynamic. However, you can specify
how many of the total number of notch filters will remain fixed, and how many will be dynamically allocated as feedback is detected. Use a greater number of fixed filters on input channels for stationary microphones. In this
instance, the room acoustics define the dominant feedback frequencies, which do not change appreciably. Use a
greater number of the dynamic filters on input channels for wireless or hand-held microphones. In this situation,
feedback frequencies change drastically as the microphone user wanders the room or sound stage. Both fixed and
dynamic filters will automatically deepen as feedback is detected.

•
•

Fixed - Once set, the frequency of a fixed filter will not change unless you manually clear all of the filters.
Dynamic - When all feedback filters are deployed and new feedback frequencies are detected, the DFR redeploys each dynamic filter at the newly detected frequency, in the order of oldest dynamic filter to newest.

You can designate the number of fixed versus dynamic filters using either
of the two techniques explained below:
To use the “Fixed” dialog:
1.

Select [Options>Fixed filters allocation] from the DFR window's menu.

2.

The “Fixed” dialog appears, as pictured to the right in Figure 7-11.

3.

Type the number of fixed filters you wish to allocate. The number of
dynamic filters adjusts accordingly.

4.

Click [OK].

To change filter allocation with the mouse:

FIGURE 7-11: “Fixed” Dialog

Position Cursor Here

1.

Position the cursor between the red brackets as indicated to the right in
Figure 7-12.

2.

The cursor changes to the horizontal resize symbol:

3.

Click and drag left to increase the number of dynamic filters, or right to
increase the number of fixed filters.
or Here

Note:

To allocate filters from the front panel, press the auto-clear button to
set all currently active filters to fixed and all currently inactive filters
to dynamic. For more information on using the DFR22 front panel
controls, see the Installation Guide.

FIGURE 7-12: Changing Filter
Allocation with the Mouse

High Q Filters and Low Q Filters
The DFR offers two width options for notch filters, as pictured below in Figure 7-13. By default, filters in the DFR
are deployed as [HIGH Q] filters. As a high Q filter gets deeper its Q increases up to 101 (1/70th of an octave).
You can also set filters to deploy at [LOW Q]. Low Q filters affect a slightly wider
range of frequencies by maintaining a Q of 14.42 (1/10th of an octave) as they
deepen.

•

To change the setting for an existing filter, click to select the filter and use
the [TYPE] drop-down menu.

•

Use the [Options] menu to select the high or low Q setting for all new
dynamic filters as they are deployed.

High Q

Low Q
FIGURE 7-13: Notch Width Options
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Adding, Modifying, and Removing Filters
To manually deploy or modify a fixed filter notch:
1.

Click to select an active fixed filter (highlighted in yellow) or, to activate a new filter, select the filter to the immediate right of the last active filter.

2.

Adjust the frequency, depth, and type as necessary.

3.

You will see the changes reflected in the response graph.
Note:

You can only select an active filter or the next adjacent inactive filter, from left
to right.

To remove all active notch filters:
1.

Click the [CLEAR] button.

2.

The “Clear” dialog appears, as in Figure 7-14.

3.

Select [Clear All Filters] and click [OK].

4.

This removes all notch filters, and flattens the response graph.
- OR -

1.

Select the [Edit>Select All] menu command.

2.

All deployed filters will be highlighted in pink to indicate they are selected.

3.

Press the Delete key.

FIGURE 7-14: “Clear” Dialog

To remove specific notch filters
1.

Click on a filter indicator to select it, or Ctrl + Click to select multiple filters.

2.

Press the Delete key - OR Click the [CLEAR] button to open the “Clear” dialog and select the [Clear Selected Filter(s)] option.

Copy and Paste
Filter notches can be copied and pasted between DFR processor windows.The DFR22 software also gives you the
ability to copy and paste any active filters from the DFR window to a Parametric Equalizer (PEQ or PEQ +CS) window. By moving fixed filters to a PEQ window, you can allocate more dynamic filters in the DFR block. You can
also conserve DSP by pasting filters from the DFR to a PEQ, then deleting the DFR block.
Note:

The bandwidth of DFR filters copied to a PEQ block may not exactly match that of the original
filter, rather, they use a bandwidth that most closely approximates the original filter.

To copy and paste filters:
1.

Click to select a single filter, or select multiple filters using one of the following methods:

•
•

Ctrl + Click on each filter you want to select.
Use the [Edit>Select All] menu command.

2.

Select the [Edit>Copy] menu command.

3.

Open the DFR or PEQ processor window where you wish to paste filter settings. Make sure to select a processor block with enough filters to accommodate those that you just copied.

4.

Select the [Edit>Paste] menu command.
Note:

When filters are part of a multiple selection, they are highlighted in pink and their parameter
settings are locked. To de-select from a multiple selection, click on any control outside the
selection area.
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Auto Clear
By default, the DFR saves the state of its filters during a preset change or power cycle. However, you can configure the DFR to automatically remove dynamic filters and changes to the depth of fixed filters according to parameters that you specify in the “Auto Clear” dialog, pictured below in Figure 7-15. Access this dialog by clicking the
[AUTO CLEAR] button in the DFR window.
After you select the [Enable Auto Clear] checkbox in the “Auto Clear” dialog, whenever a preset change or power
cycle occurs, the DFR filters will return to the state they were in when you enabled Auto Clear. In addition, you can
specify a period of time after which each dynamic filter and each change to the depth of fixed filters will be removed.
Note:

For instructions on how to set these parameters with the DFR22 front panel controls, see the
Installation Guide.

To enable Auto Clear:
1.

Ring out the system as explained in the Basic DFR Setup section on
page 69.

2.

Set all active filters to [FIXED], as explained in the Filter
Allocation section on page 70.

3.

Click the [AUTO CLEAR] button.

4.

The “Auto Clear” dialog opens, as pictured in Figure 7-15.

5.

Click the [Enable Auto Clear] checkbox.

6.

If you want each filter change to clear after a period of time, check
the [on timeout] checkbox and specify a time span from 0.1 hour to
99.9 hours. The default value is 12 hours. Each filter has its own
timer that starts from the time it is set or deepened.

FIGURE 7-15: “Auto Clear” Dialog

7.

Click [OK].

8.

The [AUTO CLEAR] button in the DFR window appears lighted in green to indicate that it is active.
Note:

After following these steps, Auto Clear is enabled only for the current DFR processor. If you want
additional DFR processors to automatically clear filter changes, you must enable Auto Clear from
each of their parameter windows.

To disable Auto Clear:
1.

Click the [AUTO CLEAR] button.

2.

In the “Auto Clear” dialog, un-check the [Enable Auto Clear] checkbox to disable it. The Auto Clear controls will
appear grayed-out.

3.

Click [OK].

4.

In the DFR window the [AUTO CLEAR] button will be grey and inactive.

© 2003 Shure Incorporated

DFR22 Software Guide

72

Ducker

Ducker
The ducker provides an easy way to use the DFR22 in an audio system that requires paging. When a paging signal is
present, the ducker attenuates or “ducks” other signals.
Block Name

Description

DUCK

Ducker

2

1
3

4
FIGURE 7-16: DUCK Window

Function
Place the ducker on an input channel strip to designate it as the paging signal. When the paging signal exceeds
the specified threshold, the ducker attenuates any other signals that are present at each output mix point to which
it is connected. It does not attenuate signals at a mix point to which the paging signal is not connected. You can
route the paging signal to output channels in the signal flow diagram, the “Matrix Mixer” window, or by checking the
[Paging Channel] check boxes in the “Ducker” window.
Note:

The ducker can only be placed on an input channel strip. Do not place more than one
ducker on the same channel. To prevent extraneous noise on the paging input from
being audible, place a gate ahead of the ducker in the signal flow diagram.
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Parameter Window Features
1) Transfer Curve Graph
The transfer curve graph displays the threshold level as a graphical element that you can position with the mouse.

2) Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. You can drag this slider
with the mouse, left and right along the top edge of the transfer curve graph, to change the threshold setting.

3) Gain Reduction Meter
This meter indicates the total gain increase or reduction you are achieving on the ducked signal(s) with the current processor settings. This feature can be toggled off and on by selecting the [Options>Gain Reduction
Meter] menu option. Its default status is on.

4) Transfer Curve Meter
In Live Mode, this meter depicts the paging signal’s input level, so you can set the threshold above ambient
noise. This feature can be toggled off and on by selecting the [Options>Transfer Curve Meter] menu option. Its
default status is on.
Note:

You may experience reduced software performance if you have a large number of meters
active overall in the DFR22 software. You can selectively turn off either the transfer curve
meter or the gain reduction meter, or both, from the [Options] menu.

Threshold Exceeded Indicator.
Signal level has exceeded the threshold
Signal level has not reached the threshold

This indicator appears lighted in yellow when
the input signal to the processor block exceeds
the specified threshold.

Threshold
This controls the gain level the paging signal must reach before the processor attenuates the
ducked signals. You can change the value by clicking on the spin buttons or by typing in a specific
value ranging from +20 dB to –60 dB. The default value is 0 dB.

Attenuation
This controls the amount of gain reduction applied to the ducked signals when the paging signal
exceeds the threshold. You can change this value by clicking on the spin buttons or by typing in a
specific value ranging –1 dB to –INF. The default value is –40 dB.

Attack
[This controls the amount of time it takes the processor to fully reduce the ducked signals' gain,
once the paging signal crosses the threshold. You can change the attack time by clicking on the
spin buttons or by typing in a specific value. The range of available values is from 1 to 5000 ms.

Hold
This controls the amount of time the processor continues to attenuate the ducked signals once the
paging signal has dropped back below the threshold. You can change this value by clicking on the
spin buttons or typing in a specific value. The range of available values is from 1 ms to 10,000 ms.
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Release
This controls the amount of time it takes the processor to return the ducked signals to their previous level once the hold time has passed. You can change this value by clicking on the spin buttons or by typing in a specific value. The range of available values is from 1 ms to 10,000 ms.

Default
Click this button to reset the processor to its system default settings.

Bypass
Bypass active
Bypass inactive

Click to pass signal through without altering it. When bypass
is active, the button appears lighted in red. The default setting is inactive.

Paging Channels
Check the box next to each output to which you want to route the paging signal.
This is the same as using the signal diagram or matrix mixer to route the signal
from this input to the outputs. Any other signal routed to the selected output mix point(s) will be attenuated
by the paging signal.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked
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Gate/Downward Expander
The gate and downward expander reduce the output level of the signal, relative to the input level, once the input level drops
below a specified threshold.
Block Name

Description

DOWN EXP

Downward Expander

GATE

Gate
3

2

4

1

6

5
FIGURE 7-17: DOWN EXP Window

Function
Use these processors to reduce or eliminate unwanted background noise. The gate mutes the input signal once it
falls below the specified threshold. The downward expander gradually reduces the gain once the input signal falls
below a the specified threshold, providing more subtle gain reduction than the gate. The gate is ideal when you
need to eliminate low-level noise that otherwise would distract from the program material. Select the downward
expander to somewhat reduce background noise in situations where gating the signal completely off would disrupt
the program.

Parameter Window Features
This section explains the features and parameter controls of the downward expander and gate using the DOWN
EXP as the example, as pictured above in Figure 7-17. These two processors are very similar in operation. Any differences between their features and functionality are noted where applicable.
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1) Transfer Curve Graph
The transfer curve graph displays the threshold level and compression ratio settings as graphical elements that
you can position with the mouse. The resulting transfer curve represents the change in the signal output level.

2) Threshold Slider
The position of the threshold slider corresponds to the setting in the threshold control. You can drag this slider
with the mouse, left and right along the top edge of the transfer curve graph, to change the threshold setting.

3) Gain Reduction Meter
This meter indicates the total gain increase or reduction you are achieving on the input signal with the current
processor settings. This feature can be toggled off and on by selecting the [Options>Gain Reduction Meter]
menu option. Its default status is on.

4) Gain Controls
Use the gain controls to adjust the input and output gain levels. The range of available gain values is between
-12dB and +12dB in 0.5dB increments, with 0dB as the default value. You can change the value using the conventions explained in the Faders section on page 33.

5) Transfer Curve Meter
When you are in Live Mode, this meter depicts the signal's input level and relative output level, so you can
monitor the processor's effect on the current program material. This feature can be toggled off and on by
selecting the [Options>Transfer Curve Meter] menu option. Its default status is on.
Note:

You may experience reduced software performance if you have a large number of meters
active overall in the DFR22 software. You can selectively turn off either the transfer curve
meter or the gain reduction meter, or both, from the [Options] menu.

6) Ratio Slider
The position of the ratio slider corresponds to the setting in the ratio control. To change the ratio setting, drag
this slider left or right along the bottom edge of the transfer curve graph, using the mouse.

Threshold Exceeded Indicator
Signal level has exceeded the threshold
Signal level has not reached the threshold

This indicator appears lighted in yellow
when the input signal to the processor
block exceeds the specified threshold

Threshold
This indicates the level below which the input signal gain must fall before the processor reduces
it. You can change the value by clicking on the spin buttons, typing in a specific value, or using
the threshold slider at the top edge of the transfer curve graph. The available range of values is
from -80.0dB to 0dB in 0.5dB increments, with a default value of -65.0dB for the gate and 40.0dB for the downward expander.
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Ratio
This indicates the amount of gain reduction at the processor output, relative to the input level. A
ratio of 4:1, for example, means a 1dB decrease in program level results in a 4dB decrease in
processor output level. You can change the value by clicking on the spin buttons, typing in a specific value, or using the ratio slider on the bottom edge of the transfer curve graph. The range of available values is from 1:1 to INF:1, in increments of 1/10th, with a default value of INF:1 for the gate and 4:1 for the
downward expander.

Attack
This indicates how much time the processor waits after the input signal gain exceeds the threshold before returning to unity gain. The available values are from 1ms to 200ms, with a default
value of 2ms for the gate and 20ms for the downward expander.

Decay
This indicates how much time the processor takes to reach the specified gain reduction. You can
change the value by clicking on the spin buttons or typing in a specific value. The range of available values is from 50ms to 1000s, with a default value of 100ms for the gate and 50ms for the
downward expander.

Hold
This indicates how much time the processor waits after the input signal gain drops below the
threshold to begin reducing gain. You can change the value by clicking on the spin buttons or
typing in a specific value. The available range of values is from 0ms to 500ms, with a default
value of 0ms.

Default
Click this button to reset the processor to its system default settings.

Bypass
Bypass active
Bypass inactive

Click to pass signal through without altering it. When bypass
is active, the button appears lighted in red. The default setting is inactive.

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW]
button appears lighted in green when the snapshot is displayed. For a more in-depth description of
the snapshot feature, see the Snapshots section on page 35.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked
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Graphic Equalizer
Graphic equalizers distribute a fixed set of broadband, constant-Q filters across the frequency spectrum, each with individual boost/cut controls. The Audio Processor provides the following types of graphic equalizers:
Block Name

Description

GEQ10

10 Band Graphic Equalizer

GEQ30

30 Band Graphic Equalizer

2

1

FIGURE 7-18: GEQ10 Window

Function
Use this processor for convenient broadband room equalization. The overall bandwidth of the processor and the
bandwidth of the individual filters depend on the type of graphic EQ you select. The GEQ10 has 10 one-octave filters between 31.5Hz and 16kHz, while the GEQ30 has 30 1/3-octave filters between 25Hz and 20kHz. the GEQ10
is shown in Figure 7-18 above.

Parameter Window Features
This section explains the features and parameter controls of the graphic EQ, using GEQ10 as an example. The
GEQ30 is identical, except for the number of bands and overall frequency range.
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1) Frequency Band Faders
You can set the frequency band faders by dragging the knob up or down with the mouse or by clicking on the
scale at the level that you would like to set. You can cut or boost any band between -18dB and +12dB in 0.5dB
increments. For more information on setting faders, see the Faders section on page 33.

2) Response Graph
This curve is a graphical representation of the results of your frequency band settings, as well as the type of filter Q you have selected.
Note:

The curve does not reflect the cumulative affect of multiple processor blocks in the signal path. To
view a combined curve, select [View>Combined Response Curve] from the main menu. For more
information, refer to the Combined Response Graph section on page 38.

Frequency
This indicates the current frequency band that you are adjusting. You can select a different
frequency band by clicking on the spin buttons. The default selection is the lowest frequency band.

Gain
This indicates the current gain setting of the selected frequency band. The range of available gain values is between -18dB and +12dB in 0.5dB increments, with a default setting of
0dB. You can change the value using the conventions explained in the Faders section on
page 33.

Filter Q Type
This indicates the type of filter Q that is set for all the frequency bands. Use the
drop-down list to change the value. The default value is “COMBINING.”
COMBINING

Averages the slope between the frequency bands, creating an
overall smooth equalization curve.

NON-COMBINING

Isolates the result of each frequency band control, providing
more independent gain adjustment.

Bypass
Bypass active
Bypass inactive

Click to pass signal through without altering it. When bypass is
active, the button appears lighted in red. The default setting is
inactive.

Flat
Click this button to set the gain of all frequency bands to zero.

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW]
button appears lighted in green when the snapshot is displayed. For a more in-depth description of
the snapshot feature, see the Snapshots section on page 35.
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Importing ASCII Files
This feature allows you to import frequency data from SIA Smaart and Gold Line TEF into the
response graph. Once in the graph, you can use the graphical data for reference as you shape
the response curve of the processor. See page 36 for instructions on how to use ASCII import.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked

Copy and Paste
You can use the [Edit] menu to copy and paste frequency band settings between graphic equalizers of the
same type.
Note:

You cannot paste settings between the GEQ10 and GEQ30 processors
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Parametric Equalizer
Parametric equalizers allow you to specify the placement, type and bandwidth of multiple filters anywhere in the frequency
spectrum between 25Hz and 20kHz. The System Processor provides the following types of parametric equalizers:
Block Name

Description

PEQ3
PEQ5

These processors provide peak/notch filters only

PEQ7
PEQ10
PEQ3+CS
PEQ5+CS
PEQ7+CS

These processors provide peak/notch filters, plus a low cut or shelf filter and a
high cut or shelf filter

PEQ10+CS
3

4

5

6

2

1
FIGURE 7-19: PEQ10 + CS Window
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Function
Use this processor for precise equalization of room response without unnecessarily affecting neighboring frequencies. Select a parametric equalizer based on the number of frequency bands you need to adjust, and whether or
not you would like to include cut or shelf filters in the processor. You can conserve DSP by selecting the fewest filters that fit your needs.
Note:

The number in the block name reflects the maximum number of peak/notch filters available for
that processor.

Parameter Window Features
This section explains the features and parameter controls of the parametric equalizer processors using the
PEQ10+CS as the example, as pictured in Figure 7-19 on the previous page. The features of the other parametric
equalizers vary only in the number of bands and the availability of the cut/shelf filters.

1) Response Graph
This curve is a graphical representation of the combined results of the filter points and handles in the response
plotter.
Note:

The curve does not reflect the accumulated effect of multiple processor blocks in the signal path.
To view a combined curve, select [View>Combined Response Curve] from the main menu. For
more information, refer to the Combined Response Graph section on page 38.

2) Response Plotter
This area of the parameter window is where you place and adjust parametric filters. It graphically displays
peak/notch filters as points and cut/shelf filters as square handles. When you initially open the processor window, the response plotter contains no filter points and, if applicable, the cut/shelf filters appear in their default
positions. Click on a filter point or handle to view its response curve and adjust settings. Refer to the Working
with Filters section on page 85 for instructions on how to add filter points

3) Filter Points
Peak/Notch filters appear in the response plotter as filter points with adjustable bandwidth controls on either
side. Click once on a filter point to make it the current selection, then adjust its settings with the mouse, keyboard controls or by using the value boxes.

4) Selected Filter
When a filter is in selection, it appears highlighted in green. Its current curve also appears highlighted in green
along the response graph, relative to zero.

5) Filter Width Handle
Click and drag these handles left and right to narrow or widen the selected filter. The position of these handles
corresponds to the value in the [WIDTH] control.

6) Cut/Shelf Filters
The high and low cut/shelf filters appear as square handles. Each handle can be used as either a cut or a shelf
filter, depending on its vertical position in the response plotter. When you first open the parameter window, the
handles operate as high and low shelf filters, with a default setting of 0db at 20kHz and 25Hz, respectively.
They become cut filters when you drag them to the bottom edge of the response plotter.
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Frequency
This indicates the frequency of the selected filter point. You can change the value by clicking on the spin buttons, using keyboard controls, or by typing a specific value. The frequency range is from 25Hz to 20kHz, with a default value of 1kHz when you add a new filter point.

Width/Slope/Type
This control changes depending on the type of filter currently in selection, as listed below. For a cut filter, you
have two slopes to choose from the drop-down menu. When a peak/notch filter is selected, you can use the
drop-down menu of preset values, or specify the width within a thousandth of an octave by typing in a value.
There are no settings in this control for shelf filters.
Filter Type

Appearance

Range of Values
From 1/70 oct through 4 oct, default value: 2/3 oct

Peak/Notch

From 100.99 Q through 0.27 Q, default value: 2.14 Q

Cut

–6 dB/oct & –12 dB/oct, default value: –6dB/oct

Shelf

None

Gain
This indicates the current gain setting of the selected filter. The range of available gain values is between -18dB and +18dB in 0.5dB increments, with a default setting of 0dB. When
you are working with a cut filter this control is disabled and displays the word “CUT.”

New
Click this button to add a new peak/notch filter to the response plotter. When you first open the window, the number below the button indicates the quantity of filter points that are available for the parametric EQ you have selected. This number decreases incrementally as you add filter points to the
response plotter. When you have reached the maximum number of filters for the processor, the button is disabled.

Clear
Click this button to clear filter settings. It opens the “Clear” dialog, which provides you with the option
to clear all filter settings, or to clear only selected filter points from the response plotter. Refer to the
Working with Filters section on page 85 for more information.

Bypass
Bypass active
Bypass inactive

Click to pass signal through without altering it. When bypass is
active, the button appears lighted in red. The default setting is
inactive.

Snapshot
This feature allows you to freeze an image of the current response curve by clicking the [TAKE] button and then display it in the background for comparison by clicking the [SHOW] button. The [SHOW]
button appears lighted in green when the snapshot is displayed. For a more in-depth description of
the snapshot feature, see the Snapshots section on page 35.
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Importing ASCII Files
This feature allows you to import frequency data from SIA Smaart and Gold Line TEF into the
response graph. Once in the graph, you can use the graphical data for reference as you shape
the response curve of the processor. See page 36 for instructions on how to use ASCII import.

Link Indicator
This displays the link status of the processor. Any setting you change in a linked processor will change for all
other processors in the same link group. For a complete explanation of linking and link groups, see the
Linking section on page 24.
Processor Linked
Processor Not Linked

Working with Filters
When you initially open the parameter window of a parametric EQ, there are no peak/notch filters in the response
plotter. Add filter points as you need them, up to the maximum number available for the selected processor block.
To add a new filter point:
1.

Click the [NEW] button.

2.

A filter point appears at 0dB with a default frequency value of 1kHz and a bandwidth of 2/3 octave.

To remove all filter points:
1.

Click the [CLEAR] button or select [Edit>Clear Filters] from the parameter window menu bar.

2.

The “Clear” dialog appears, as pictured to the right in Figure 7-20.

3.

Select [Clear All Filters] and click [OK]. This removes all filter points
from the response plotter and returns the cut/shelf filters to the
default settings.

To remove specific filter points:
1.

Click on a filter point to select it, or Ctrl + Click to select multiple filters.

2.

Press the Delete key - OR - Click the [CLEAR] button to open the
“Clear” dialog and select the [Clear Selected Filter(s)] option.
Note:

FIGURE 7-20: “Clear” Dialog

You cannot remove cut/shelf filter handles, however you can return them to their default settings by using [CLEAR] or Delete.

Adjusting Filters in the Response Plotter
You can change filter settings by dragging the filter points and handles with the mouse.
To adjust gain and frequency:
1.

Position the cursor over the center of the filter point or handle.

2.

The cursor changes to the move symbol:

3.

Click and drag the filter left or right to adjust frequency, and up or down to adjust gain.

Note:

The response plotter displays a curve only for the selected filter. The combined curve is displayed in the response graph.
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To adjust filter point bandwidth:
1.

Position the cursor over either of the filter’s bandwidth control points.

2.

The cursor changes to the horizontal resize symbol:

3.

Click and drag the control point left or right to set the bandwidth.,

Fine Tuning Parameters
You can precisely adjust parameters for the selected filter point using any of the following methods:

•
•
•

Enter a number into any of the parameter boxes
Using the spin buttons (or drop down box) next to the parameter boxes
Using the keyboard controls

Keyboard Controls
You can use the following keyboard controls to make fine adjustments to the currently selected filter.
Keystroke

Result
¬

Decreases frequency by one screen pixel

®

Increases frequency by one screen pixel



Increases gain by 0.5 dB

¯

Decreases gain by 0.5 dB

Shift + ¬

Decreases frequency by 1/3 octave

Shift + ®

Increases frequency by 1/3 octave

Ctrl + ¬

Decreases the bandwidth of a filter point by small increments

Ctrl + ®

Increases the bandwidth of a filter point by small increments

Shift + 
or Page Up
Shift + ¯
or Page Down
Spacebar or right
mouse click

Note:

Increases gain by 3 dB
Decreases gain by 3 dB
Sets gain to 0 dB

Nudging the frequency by one screen pixel changes the value by approximately 1/100
of an octave, or 1%

Copy, Cut and Paste
Filter points can be copied, cut and pasted between parametric EQ windows, given the following considerations:

•
•

There are a sufficient number of available filter points in the parameter window where you are pasting.
Cut/Shelf filter settings can only be copied and pasted between PEQ+CS processors.
Note:

The Cut command is not available for cut/shelf filter handles.

To copy and paste filters:
1.

Click to select a single filter, or select multiple filters using one of the following methods:

•
•

Ctrl + Click.
Use the [Edit>Select All] menu command.

2.

Select the [Edit>Copy] menu command.

3.

Open the parameter window of the parametric EQ where you wish to paste filter settings.

4.

Select the [Edit>Paste] menu command.

Note:

When filters are part of a multiple selection, they are highlighted in pink and their parameter settings are locked. To de-select from a multiple selection, click on any control in the
parameter window, or on a filter outside the selection area.
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SECTION 8

Control Pins

The pin connector on the rear panel of the DFR22 Audio Processor allows the installer to connect custom external hardware such as switches and potentiometers for volume adjustment, channel muting, and preset selection. It can also be
used for interfacing with Crestron or AMX logic control cards. This type of simple control provides end users with a means
to control specific functions without a computer.

Control Pins Overview
External device control is established at three different levels: external connections, pin configuration, and processor mapping. In the illustration below, the device is configured for the following external control:

•
•
•

One-to-one switching between two presets.
Adjusting overall system output gain with a potentiometer.
Muting an input channel with a latching switch.

FIGURE 8-1: The Three Levels of External Device Control

Level One: External Connections

When the device is initially installed, determine what type of external control the sound system calls for, and wire
the appropriate hardware accordingly. Refer to the Installation Guide for instructions and wiring diagrams.
Level Two: Pin Configuration

In the DFR22 software, use the “Pin Configuration” section of the “Control Pins” window to select the hardware that
is connected to the device. This configuration is stored as a global setting in the device, and can also be saved as
a computer file. Refer to the “Pin Configuration” section on page 91 for instructions.
Level Three: Processor Mapping

Once the device is configured to recognize external control hardware, assign input and output channels to the control connections. Use the “Processor Mapping” section of the “Control Pins” window in the DFR22 software. Each
preset stores a unique processor map. Refer to the “Processor Mapping” section on page 95 for more information.

© 2003 Shure Incorporated

DFR22 Software Guide

87

Control Pins Tutorial

Control Pins Tutorial
This tutorial provides step-by-step instructions on how to configure the DFR22 for external control. It can also be accessed
by clicking the [Tutorial] button in the upper right-hand corner of the “Control Pins” window, so you can follow the instructions as you perform these steps. For more in-depth explanation of the “Control Pins” window features and functions, refer
to The “Control Pins” Window section on page 91.

A. Go to Design Mode and open the “Control Pins” window.
Click the [Design Mode] button on the control bar of the main window and select [Devices>Control Pin Configuration] from the main menu.

B. Are you configuring the control pins for preset selection?
•

If NO, skip to step D.

•

If YES, enter the number of presets you will be selecting in the [# Presets] field.
Note:

When you configure the control pins for preset switching, the
preset selector on the front panel of the DFR22 is disabled.

C. What type of control will you use for preset switching?
Specify your selection from the drop-down menu in the [Encoding Type] field.

•

Priority: one preset per control pin (use momentary or latching switches). This option switches between a
maximum of four presets.

•

Binary: triggers specific presets with a combination of open and closed pins (use latching switches).
Max # Presets

•

# Pins

2

1

4

2

8

3

16

4

DRS-10/Custom: 10-position rotary switch that changes presets depending on resistor value. The DRS-10 is
an optional Shure accessory, or you can create a custom circuit. For a table of resistor values as they correspond to presets, refer to page 93. This option switches between a maximum of ten presets and uses one
control pin.

The connection blocks in the “Control Pins” window will allocate the number of pins required to switch presets
according to the settings you specify in the [# Presets] and [Encoding Type] fields. These pins appear as the Preset Control Block on the left side of the window.

IMPORTANT NOTE ON PRESET SWITCHING:
Once preset control is enabled for the control pins, you cannot change presets
from the computer or the DFR22’s front panel preset selector. However, the
front panel indicator will still display the current live preset.
If you need to switch presets from the computer or the DFR22’s front panel
after you have enabled the control pins, you can do so by disabling the preset
control block in the “Control Pins” window.
FIGURE 8-2: Disable the Preset
Control Block
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To disable the preset control block:
1.

Click and hold on the drop-down arrow to the right of the preset control block and select [Disable].

2.

A check mark appears next to this option when the block is disabled. In Live Mode the change will be
made as soon as you select [Disable]. If you are Design Mode you will need to store the pin configuration
again by selecting [Configuration>Store to Device] from the “Control Pins” window menu.

3.

When you are finished selecting presets from the PC, select [Disable] again to restore preset selection
control to the control pins.

D. Are you going to control gain using the control pins?
•
•

If NO, continue to step E.
If YES, select a potentiometer for one of the connection blocks, or select a
momentary switch on each of two connection blocks; one for incrementing
gain up and the other for incrementing gain down.

There is a drop-down menu to the right of each connection block. Click and hold
with the mouse to select from the list of available hardware connections. Select
[Moment] for a momentary switch or [Pot] for a potentiometer.

E. Are you going to control channel muting using the control pins?
•
•

FIGURE 8-3: Connection Block
Drop-Down Menu

If NO, continue to step F.
If YES, select either [Moment] or [Switch] from the connection block drop-down menu according to the following
parameters:

>
>
>

For press to mute and press again to unmute using a momentary switch, select [Moment].
For press and hold to mute, release to unmute using a momentary switch, select [Switch].
For position one mute, position two unmute using a latching switch, select [Switch].

F. Store the Pin Configuration to the device.
1.

Select [Configuration>Store to Device] from the “Control Pins” window menu.

2.

If the “Select Device” dialog appears, click to select the DFR22 then click [OK].

Note:

You can also save a pin configuration to the PC if you are not connected to the device, then store it to
the device later. Refer to the “Pin Configuration” section on page 91 for instructions.

G. Are all of your presets stored to the device?
•
•

If YES, continue to step H.
If NO, create and store your presets to the device. Refer to the Creating a Preset section on page 17 and the
Device Presets section on page 29 for more information.

H. If you haven’t already done so, physically connect your control hardware to the DFR22 control
pins according to the pin configuration you specified in the “Control Pins” window.
•
•
I.

If you are using the control pins for preset switching only, you are finished.
If you are using control pins for gain adjustment or muting, continue to step I.

Go to Live Mode and open the “Control Pins” window.
Click the [Live Mode] button on the control bar of the main window and select [Devices>Control Pin Configuration]
from the main menu.
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J. Are you using any potentiometers?
•
•

If NO, continue to step L.
If YES, calibrate each potentiometer. Click the [Calibrate] button under the potentiometer control block to start the calibration wizard. You must calibrate each potentiometer separately.
Note:

If you do not calibrate the potentiometer, the default calibration is for a 100k
audio taper potentiometer.

FIGURE 8-4: Calibrate
Button

K. Set the gain range for each potentiometer.
1.

Click the [Gain Range] button.

2.

The “Range Edit” dialog opens.

3.

Specify the minimum and maximum values.

4.

Click [OK].

L. Map the input and output channels to the control connections.
The input and output channels are listed under each control pin connection block. Click to check the corresponding
checkbox for each channel you wish to control.

M. Are you using any momentary switches for gain control?
•
•

If NO, continue to step N.
If YES, set the increment amount and maximum and minimum gain values.
1.

Click the [Gain Up Limit] or [Gain Down Limit] button.

2.

The “Set Gain Maximum” or “Set Gain Minimum” dialog opens.

3.

Specify the increment amount and gain limit settings.

4.

Click [OK].

See the Momentary Switches section on page 96 for more information.

N. Repeat steps K through M for each preset stored in the DFR22 device.
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The “Control Pins” Window
The “Control Pins” window is an interface for both configuring control pins globally at the device level, and assigning input
and output gain processors to controllers for each preset individually. Access this window by selecting the [Devices>Control Pins Configuration] menu command from the main window.

1

5

2

6

3

4

FIGURE 8-5: “Control Pins” Window
1.

Preset Switching Controls: Use these controls to specify how many presets you will be switching and what type
of hardware control will perform the switching. Enter the number of presets first, then specify the encoding type.

2.

Preset Control Block: This graphically displays the control pins that are allocated to preset switching. Its features and appearance depend on the settings that you specify in the Preset Switching Controls.

3.

Connection Block: Each block displays what type of control hardware you have specified for the corresponding pin.

4.

Connection Block Drop-Down Menu: Use this menu to specify the type of control for the connection block.

5.

Pin Configuration: Settings in this section of the window apply to the DFR22 at the device level. See Pin Configuration below for more information.

6.

Processor Mapping: Settings in this section of the window are unique to each preset. See the “Processor
Mapping” section on page 95 for more information.

“Pin Configuration”
Use this section of the “Control Pins” window to configure the DFR22 to properly recognize any control pin connections that
are wired to external hardware. When you first open the window, all the connections are disabled and there is no differentiation between the function of the pins. Once you define how many pins will be used for preset control, if any, the display
assigns those pins to preset control and any remaining pins can be allocated for controlling input and output channel gain
and muting.
Note:

You must be in Design Mode to create or change the pin configuration.
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These settings are stored at the device level. They are not stored with presets, and do not change when you switch
between presets in the device. You can store this configuration to the computer if you are working offline from the DFR22,
or as a backup.

Preset Encoding Settings
When you are going to use the control pins to switch between presets, you must specify values in these controls
before setting any other parameters in the “Control Pins” window.
Note:

Once you have established preset switching with the control pins, the preset selector on the front
panel is disabled and you cannot use the computer to change presets. In Live Mode you can disable the control pins by clicking on the preset control block, or by selecting [Disable] from the
drop-down menu on the right of the preset control block. The block will be greyed out when it is
disabled. To re-establish external preset control, in Live Mode select “Disable” again, or click on
the preset control block.

# Presets
Use this control to specify the number of presets the control pins will select. The range of values is one to 16, with a default value of one. Enter a value in this box before selecting an
[Encoding Type].

Encoding Type
Use this control to specify how the presets will be selected from the control pins. The available settings depend on the number of presets you have specified in the [# Presets] field,
as described below. The default value is “None.”
Priority or One-to-One Encoding
This setting assigns each pin connection to a unique preset number. It allows you to
switch between up to four presets. Use momentary or latching switches for this type of
encoding.
The preset control block displays a text box for each control pin. The values initially
default to presets number one through four. You can specify different preset numbers
by clicking in each text box and typing in a number, from one to sixteen. If a user inadvertently presses a combination of switches when making a selection, the device will
switch to the preset in the [Highest Priority] position.

FIGURE 8-6: Preset
Control Block for Priority
Encoding

Binary Encoding
This setting selects presets using a binary setting at the control inputs, as displayed
beneath the preset control block. It allows you to switch between up to 16 presets. Use
latching switches for this type of encoding. The binary code corresponds to the logic
state at the control pin inputs.

•
•

Logic 0 = pin lifted
Logic 1 = pin grounded
FIGURE 8-7: Preset
Control Block for Binary
Encoding
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There is a text box for each binary setting at the control pins. The default values
begin at preset one for binary setting 0 and increment up to preset sixteen for
binary setting 1111. You can change the preset that is selected by each logic
combination by clicking in each text box and typing in a different preset number,
from one to sixteen. Refer to Appendix A: Binary Encoding Tables for the default
preset values.
DRS10 or Custom Switch Encoding
This setting selects presets using a corresponding resistor value at the control
pin input. You can select a maximum of ten presets with this encoding type. The
DRS10 is an optional Shure accessory, or you can create a custom circuit.
PRESET

RESISTOR

PRESET

RESISTOR

#

VALUE

#

VALUE

97 kW – ¥ W

1

6

Binary Preset Encoding
Max # Presets

# Pins

2

1

4

2

8

3

7.8 – 9.3 kW

2

44 – 60 kW

7

5.2 – 6.3 kW

3

26 – 32 kW

8

3.3 – 4.1 kW

4

17 – 20 kW

9

1.9 – 2.5 kW

5

11.3 – 13.6 kW

10

0.63 – 1.1 kW

FIGURE 8-8: Preset Control
Block for DRS10/Custom
Encoding

Connection Blocks
The number of connection blocks that appear in the window depends
on how many pins are available after you have specified preset control. Assign hardware controls to a pin by making a selection from the
drop-down menu on the right-hand side of the block. The hardware
control(s) can be alternately enabled and disabled by clicking on the
block with the left mouse button, or selecting [Disable] from the dropdown menu.
Note:

Enabled
Connection

Disabled
Connection

FIGURE 8-9: Connection Blocks

If you are in Design Mode, to enable or disable the hardware connections you must store the pin
configuration to the device.

Latching Switch [Switch]
Use the latching switch selection for muting input and output channels. This setting is generally for
an external controller that flips between two positions. It can also be used with a momentary
switch, in which case the channel will be muted when the switch is depressed, and unmuted when
it is released.

Momentary Switch [Moment]
Use the momentary switch setting for muting input and output channels. This setting is for an external momentary switch that will turn muting on or off each time the switch is depressed. It can also be
used for incrementing gain up and gain down. When used for incrementing gain, you need to set up
the gain minimum, maximum, and increment amount for each preset. Refer to the Momentary
Switches section on page 96 for more information.

Potentiometer [Pot]
Use the potentiometer setting for adjusting input or output gain. Click the [Calibrate] button to calibrate the control input to the range of the attached potentiometer. If you do not calibrate the potentiometer, the default calibration is for a 100k audio taper potentiometer with a tolerance of +/–20%.

© 2003 Shure Incorporated

DFR22 Software Guide

93

“Pin Configuration”

Creating a New Control Pin Configuration for the Device
1.

Go to Design Mode.

2.

Select [Devices>Control Pin Configuration] from the main menu.

3.

The “Control Pins” window opens.

4.

Configure preset control.
a) Enter the number of presets in the [# Presets] value box.
b) Select an encoding type from the [Encoding Type] pull-down menu.
c) The preset control pins block appears.
d) If you are using priority or binary encoding, enter the appropriate preset numbers under the preset
control block.

5.

Configure any remaining pins for external controllers by making a selection from the drop-down menu on
the right-hand side of each connection block.

6.

Select the [Configuration>Store to Device] menu option.

7.

If the “Select Devices” dialog appears, select the device and click [OK].

8.

The pin configuration is stored to the device

Saving a Control Pin Configuration to PC
1.

Follow steps 1 – 5 above.

2.

Select the [Configuration>Save to PC] menu option.

3.

The “Save Config As” dialog opens.

4.

Navigate to the appropriate directory, enter a file name and click [OK].

5.

The configuration is stored to the computer as a file with a “.d22pin” extension.

Editing a Control Pin Configuration in the Device
1.

Go to Design Mode.

2.

Select [Devices>Control Pin Configuration] from the main menu.

3.

The “Control Pins” window opens.

4.

Select the [Configuration>Recall From Device] menu option.

5.

If the “Select Devices” dialog appears select the device and click [OK].

6.

The “Control Pins” window is populated with the current pin configuration.

7.

Make the necessary changes.

8.

Select the [Configuration>Store To Device] menu option.

9.

If the “Select Devices” dialog appears select a device and click [OK].

10.

The pin configuration is stored to the device.
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“Processor Mapping”
Use this section of the “Control Pins” window to specify which input and output channels the external hardware will control.
The input and output channels are listed in a column below each connection block to which a controller has been allocated.
In order for the external control hardware to control gain and channel muting, each preset in the device must be mapped to
the control connections.
Note:

Before creating a processor map, you must first create a control pin configuration and store it to
the device.

Processor mapping can be created while you are in Live Mode or Design Mode. When you are in Live Mode the title bar of
this section of the window is blue, in Design Mode it is black. In Live Mode, any changes you make to processor mapping is
directly saved and applied to the current live preset.

Mapping Hardware Controls to Input and Output Channels
You can map any combination of input and output channels to a controller. For momentary switches, there are
three possible functions to map for each channel: gain up, gain down, and mute. Each input or output channel can
be mapped to only one of these three functions at a time. For example, you cannot set the same channel to both
gain up and to mute.
To map an input or output channel to a controller:

•

Click a checkbox to map the corresponding input or output channel to a control.

•

To de-select the checkbox, click on it again.
Processor checkbox selected for mapping.
Checkbox de-selected.

Gain Control Settings
In addition to mapping the input and output channels to gain control, you must also specify the allowable range
within which the end user can adjust the gain. As this is part of the processor mapping, these settings are saved
with each preset individually.

Potentiometers
Under each potentiometer control block there is a [Set Gain Range] button. If
you do not specify a gain range for each control, it defaults to -¥ dB to +10 dB.
To set the gain range of a potentiometer:
1.

Click the [Set Gain Range] button.

2.

The “Range Edit” dialog opens.

3.

Enter the minimum and maximum allowable gain adjustment. The minimum level is -¥ dB and the maximum is +10 dB.

4.

Click [OK].
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Momentary Switches
Under each momentary switch control block there are [Gain Up Limit]
and [Gain Down Limit] buttons. In addition to setting the maximum or
minimum gain of a momentary switch designated as a gain control,
these buttons allow you to set the increment in dB by which the control
raises or lowers the gain. When a gain control is pressed, it immediately raises or lowers the gain by the amount specified. If a gain control
is pressed and held, it immediately raises or lowers the gain by the
amount specified. Then, after a delay of 1000 ms, it will continue to
increment or decrement the gain every 120 ms that the control is held.
If you do not specify a gain maximum and increment for a gain up control, it will use the default values of +10 dB maximum in 2 dB steps. If
you do not specify a gain minimum and increment for a gain down control, it will use its default values of -¥ dB minimum in 2 dB steps.
To set the gain limits for a momentary switch:
1.

Click to select an input or output channel for gain up control.

2.

Click the [Gain Up Limit] button.

3.

The “Set Gain Maximum” dialog opens.

4.

Enter the upper gain limit (maximum +10dB).

5.

Enter the increment that the gain will increase each time the switch is pressed (maximum 10dB).

6.

Click [OK].

7.

Click to select an input or output channel for gain down control.

8.

Click the [Gain Down Limit] button.

9.

The “Set Gain Minimum” dialog opens.

10.

Enter the lower gain limit (minimum -¥ dB).

11.

Enter the increment the gain will decrease each time the switch is pressed (maximum 10dB).

12.

Click [OK].

FIGURE 8-11: Momentary Switch
Processor Mapping

Creating a Processor Map
By assigning external hardware to the inputs and outputs you want to control, you create a processor map. You
can use one of the following methods:

•
•

In Live Mode create a processor map for each preset in the device, one by one.
In Design Mode open a preset file from the PC, or recall it from the device, and store a processor map with it.

To create a processor map in Live Mode:
1.

Go to Live Mode and switch to the preset you want to modify.

2.

Select [Devices>Control Pin Configuration] from the main menu.

3.

The “Control Pins” window opens with the input and output channels listed under the connection blocks.

4.

For each connection block, click the processor mapping checkboxes next to the channels that will be controlled by the hardware connection.

5.

Set the gain range for any potentiometers and the gain limits and increments for any momentary switches you
are using for gain control.

6.

The mapping is automatically saved with the preset in the device every time a change is made in Live Mode.

7.

To set up another processor map, switch to another preset (it is not necessary to close the “Control Pins” window).
Note:

You must set up a processor map for each preset in the device with which you want the hardware
controllers to function.
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“Processor Mapping”

To create a processor map in Design Mode:
1.

Go to Design Mode.

2.

Click the [Open] button on the control bar of the main window.

3.

The “Open Preset” dialog appears.

4.

Select the appropriate preset file and click [OK].

5.

The selected preset populates the signal flow diagram.

6.

Select [Devices>Control Pin Configuration] from the main window.

7.

The “Control Pins” window opens.

8.

Load a pin configuration using one of the following methods

•
•
•

Select the [Configuration>Open from PC] menu option and open a “.d22pin” file you have stored on PC.
If you are connected to the DFR22, select the [Configuration>Recall from Device] menu option.
If you have not created a pin configuration, see the “Pin Configuration” section on page 91.

9.

For each allocated connection block, click the processor mapping checkboxes next to the channels that will be
controlled by the hardware connection.

10.

Go back to the main window (it is not necessary to close the “Control Pins” window).

11.

Save the preset file to PC (refer to the Revising Preset Files section on page 28 for instructions).
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Security

SECTION 9

Security is an optional feature that allows the installer, or other security administrator, to restrict the end user's access to
DFR22 settings from the front panel or with the computer.
Note:

You must be connected to the device to configure any security settings, except for individual processor security.

Front Panel Lockout
Access to the front panel controls can be locked out so the end user cannot make
any changes to DFR processor settings, or change presets. To lock out all front
panel controls, set the fifth DIP switch on the rear panel of the DFR22 to the down
position. You can use the software to override the DIP switch and selectively lock
out specific controls, while allowing access to others.
To selectively lockout front panel access:
1.

Select [Security>Front Panel Lockout] from the main menu.

2.

The “Front Panel Lockout” dialog opens, as pictured in
Figure 9-1.

3.

Click the [Override and Disable Dip Switch] checkbox.

4.

Click the checkbox opposite each front panel control for which you
wish to restrict user access.

FIGURE 9-1: “Front Panel Lockout” Dialog

You can also password protect the lockout settings so only the security administrator can make changes to the front panel
lockout with the computer. For more information, read the following section on computer access.

Restricting Computer Access
The administrator is the individual who sets the device's password and the access level at which it will operate after it is
installed. There are three different user access levels for the device:

Level One
When the device is set to level one, the user has unrestricted access to Audio Processor functions, except for
two functions that are always protected by the administrator password:
1.

Setting the security level of the device.

2.

Changing the administrator password.

Level Two
When the device is set to level two, the user has limited access, as defined by the security administrator. The
following DFR22 access can be allowed for level two:

•
•
•
•

Preset changes via PC.
Changes to Matrix Mixer signal routing.
Changes to front panel lockout settings.
Access to modify processor settings for any blocks that are not locked by the administrator (see the Individual Processor Security section on page 101 for more information).
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Restricting Computer Access

Level Three
This level permits read-only access to DFR22 settings for the current live preset.
Note:

Security only affects access through the software interface and front panel. It does not
restrict external device control via the control pins.

Establishing Device Security
Establishing security should be the final phase in setting up the device. There are two primary steps in setting the
device security:
1.

Creating a Password

2.

Setting the User Access Level

Create a Password
Before you can set the user access level in the device, you must create
the password that protects your access as the security administrator.
To create a password:
1.

Select [Security>Set Password] from the main menu.

2.

The “Create Password” dialog appears, as pictured in
Figure 9-2.

3.

Enter a password in the [Administrator Password] field.

4.

Tab to the [Confirm Password] field and retype the password.

5.

Fill out the [Administrator Name] and [Phone or Contact Info] fields.

Note:

All entries in the “Create Password” dialog are limited to a
length of fifteen characters.

FIGURE 9-2: “Create Password” Dialog

Set the User Access Level
Once you create a password, the device is automatically set to user
access level one. If access to the device must be further restricted, set
the device to the appropriate access level.
To set the user access level:
1.

Select [Security>Level] from the main menu.

2.

The “Input Password” dialog appears, as pictured to the right in
Figure 9-3.

3.

Enter the password and click [OK].

4.

The “Set Security Level” dialog appears, as pictured in Figure 9-4.

5.

Click the radio button to the left of the appropriate level.

6.

Specify custom options for level two, if applicable.

7.

Click [OK].

FIGURE 9-3: “Input Password” Dialog

Changing Device Security
In the event that changes to device configuration or security settings are
required after access has been restricted, you must first change the device
security back to user access level one before you can continue.
Note:

The security administrator password is required for these functions.
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Restricting Computer Access

Changing the Access Level
Follow the instructions listed above for setting the access level.

Changing the Password
To change an existing password:
1.

Select [Security>Set Password] from the main menu.

2.

The “Set Password” dialog appears, as pictured in Figure 9-5. The
cursor is located in the [Old Password] field.

3.

Enter the current password.

4.

Tab to the [Administrator Password] field and enter the
new password.

5.

Tab to the [Confirm Password] field and retype the new password.

6.

Change the [Administrator Name] and [Phone or Contact info]
if necessary.

7.

Click [OK].

Note:

FIGURE 9-5: “Set Password” Dialog

All entries in the “Set Password” dialog are limited to a length of fifteen characters.

Removing Security
Device security can be completely reset to default status so that others may set an administrator password and
define user access levels.
To remove password protection:
1.

Select [Security>Set Password] from the main menu.

2.

The “Set Password” dialog appears, as pictured in Figure 9-5, above.

3.

Type the current password in the [Old Password] field.

4.

Optionally, delete the administrator name and contact info.

5.

Leave the [Administrator Password] and [Confirm Password] fields blank.

6.

Click [OK].

7.

All access restrictions are removed.

Note:

Any individual processor block security attributes remain, but they are not in effect until the
device is set to user access level two.
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Restricting Computer Access

Individual Processor Security
Individual processor security locks out access to specific processor blocks in a preset. You can lock access to a
single block, multiple blocks, or all blocks in a preset. You would use this feature, for example, if you wanted the
end user to be able to change gain settings but not PEQ settings. A locked processor can still be opened to monitor meter levels or view settings.
While the user access level is device specific, processor block security is preset specific. Moreover, individual processor security is a separate attribute of each block. For example, you can set the lock attribute on a block, and
when you copy that block, its security attribute is copied with it. This attribute remains whether you are working in
Design Mode or Live Mode.
To lock processor blocks:
1.

Go into Live Mode with the device.

2.

Verify that the device is set to Security - Level 1.

3.

Click to highlight a processor block, or Ctrl + Click to make a multiple selection.

4.

Select [Security>Level 2>Lock Selected] from the main menu.

5.

A check mark appears beside this menu option to indicate the selected processor is locked.

6.

Set the device to user access level two, as explained in the Set the User Access Level section on page 99.
Note:

Individual processor security applies to computer access only. It does not affect access to processor settings from the front panel or the control pins.
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Printing Reports

SECTION 10

The DFR22 software provides printed reports to document all of the presets and settings that are stored in the device.
These reports are designed for the following uses.
1.

To document the device configuration for the customer and end user.

2.

To provide a hard-copy backup so that if necessary the device configuration can be reconstructed.
Note:

The reports are output directly to the printer, rather than to a file, so you must be connected to
a printer to use this feature.

To print DFR22 reports:
1.

Select [File>Print] from the main menu.

2.

The “Choose Report” dialog opens, as pictured to the right
in Figure 10-1.

3.

Click to select the report you would like to print.

4.

A dialog will open for the report you have specified.

5.

Specify the information to include in the report, as described in the following section.

6.

Click [OK].

7.

The Windows Print dialog appears.
FIGURE 10-1: “Choose Report” Dialog

Device Information
The Device Information report lists all device-level information, except for the security password. When the “Device Information” dialog opens, select the device for which you would like to print a report from the [Device] pull-down list. Enter the
information pertinent to the selected device and click [OK]. The information you enter here appears only on the immediate
report; it is not stored for future use. Refer to page 101 for a sample of this report.

FIGURE 10-2: “Device” Dialog
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Preset Information and Current Preset Information

Preset Information and Current Preset Information
The Preset Information report lists the details of a specific preset that is stored in the device. When the “Individual Presets
from Device” dialog opens, select the device for which you would like to print a report from the [Device] pull-down list. Then
select the preset for which you would like to print a report and click [OK]. Refer to pages 102 and 103 for a report sample.
The Current Preset Information report is identical. It lists the details of the currently displayed preset.

FIGURE 10-3: “Individual Presets from Device” Dialog

FIGURE 10-4: “Currently Displayed Preset”
Dialog

Processor Information
The Processor Information report lists the settings of one or more processor
blocks. The “Individual Processor Blocks” dialog displays a list of all fixed and
drag-and-drop processors from the currently displayed preset. Click to select a
processor, or Shift + Click to select more than one, then click [OK]. Refer to
page 104 for a sample of this report.

FIGURE 10-5: “Individual Processor Blocks”
Dialog
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Report Samples

Report Samples
DEVICE INFORMATION
Installation Information:
Location:

4325 W. Division, Chicago

Client:

Sacred Heart School

Designer:

Bob Reiling

Installer:

RC Communications

System Description:
Main Gymnasium Audio Processor
Hardware Information:
ShureLink Device ID:

15

Device Name:

Gymnasium

Control Input Configuration:
Pin-1: Encoding Type: Priority, Mapped to preset: 1
Pin-2: Encoding Type: Priority, Mapped to preset: 2
Pin-3: Switch
Pin-4: Potentiometer
Preset Information:
Total Presets:

4
Preset 1

Concert

Preset 2

Assembly

Preset 3

Game

Preset 4

Dance

1 of 1
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Report Samples

PRESET INFORMATION:

Preset ID:

2

Preset Name:

Assembly

Description:

Preliminary tuning.

Control Input Pin Mapping:
Pin-1: Reserved for Preset Control - See Device Information
Pin-2: Reserved for Preset Control - See Device Information
Pin-3: Mutes: Input 1 2
Pin-4: Gains: Input 1 2, Gain Range: -inf to 0 dB

1 of 2
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Report Samples

Drag and Drop Processors:

Input-1, Slot-1, Processor: DFR16
Input-1, Slot-2, Processor: PEQ 10CS
Input-1, Slot-3, Processor: GEQ30
Input-1, Slot-4, Processor: LIM
Input-1, Slot-5, Processor: N/A
Input-2, Slot-1, Processor: DFR16
Input-2, Slot-2, Processor: PEQ 10CS
Input-2, Slot-3, Processor: GEQ30
Input-2, Slot-4, Processor: LIM
Input-2, Slot-5, Processor: N/A
Output-1, Slot-1, Processor: DLY 2s
Output-1, Slot-2, Processor: N/A
Output-1, Slot-3, Processor: N/A
Output-1, Slot-4, Processor: N/A
Output-1, Slot-5, Processor: N/A
Output-1, Slot-6, Processor: N/A
Output-2, Slot-1, Processor: DLY 2s
Output-2, Slot-2, Processor: N/A
Output-2, Slot-3, Processor: N/A
Output-2, Slot-4, Processor: N/A
Output-2, Slot-5, Processor: N/A
Output-2, Slot-6, Processor: N/A

2 of 2
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Report Samples

PROCESSOR INFORMATION:

Input Gain Block
Security: Unlocked
Input-1: Name: Music, Operating Level: +4 dBu, Polarity: +, Gain: –4.5dB, Mute: Off, Link Group N/A
Input-2: Name: Speech, Operating Level: +4 dBu, Polarity: +, Gain: 0.0dB, Mute: Off, Link Group N/A

Input-1, Slot-1, Processor: DFR16
Name: DFR 16, Link Group: N/A, Security: Unlocked
Bypass: Off
Autoclear: Disabled
Front Panel Assignment: ROW A
Fixed Filters: 3, New Filters: High
Filter: 1, Freq: 65Hz, Depth: –3.0dB, Type: HighQ
Filter: 2, Freq: 171Hz, Depth: –3.0dB, Type: HighQ
Filter: 3, Freq: 2.5kHz, Depth: –3.0dB, Type: HighQ

Input-1, Slot-2, Processor: PEQ10CS
Name: PEQ with CS, Link Group: N/A, Security: Unlocked
Bypass: Off
Filter: L, Type: Shelf, Freq: 0.1kHz, Gain: -18.5dB
Filter: H, Type: Shelf, Freq: 10kHz, Gain: -18.5dB
Filter: 3, Freq: 4.3kHz, Gain: –9.0dB, Width(oct): 2/3, Width(Q): 2.14
Filter: 4, Freq: 0.7kHz, Gain: –4.5dB, Width(oct): 1.249, Width(Q): 1.12
Filter: 5, Freq: 0.2kHz, Gain: –9.0dB, Width(oct): .350, Width(Q): 4.11
Filter: 6, Freq: 0.1kHz, Gain: –6.0dB, Width(oct): 1, Width(Q): 1.41
Filter: 7, Freq: 6.8kHz, Gain: –6.0dB, Width(oct): 1/6, Width(Q): 8.65

Input-1, Slot-3, Processor: GEQ30
Name: Graphic EQ, Link Group: N/A, Security: Unlocked
Bypass: Off, Filters Type: Combining
Filter: 31.5 Hz, Gain: 1.5dB
Filter: 800 Hz, Gain: –1.5dB
Filter: 250 Hz, Gain: 0.5dB
Filter: 3.15kHz, Gain: –0.5dB

Filter: 8kHz, Gain: 3.0 dB
Filter: 16 kHz, Gain: 0.5dB

Input-1, Slot-4, Processor: LIM
Name: Limiter, Link Group: N/A, Security: Unlocked
Bypass: Off
Threshold: 9.5 dB, Attack: 2ms, Ratio: 100.0, Decay: 50ms
Input Gain: 0.00, Output Gain: 0.00

1 of 2
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Appendix A: Binary Encoding Tables

SECTION 11

The following tables list the binary encoding for DFR22 presets. Apply this encoding to the control input pins to switch the
device to the corresponding preset.
Note:

0 = Pin Lifted, 1 = Pin Grounded

TABLE 1. One-Pin Binary Encoding
PRESET

#

PIN

1

0

2

1

1

TABLE 2. Two-Pin Binary Encoding
PRESET

#

PIN

1

PIN

1

0

0

2

0

1

3

1

0

4

1

1

2

TABLE 3. Three-Pin Binary Encoding
PRESET

#

PIN

1

PIN

2

PIN

1

0

0

0

2

0

0

1

3

0

1

0

4

0

1

1

5

1

0

0

6

1

0

1

7

1

1

0

8

1

1

1
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TABLE 4. Four-Pin Binary Encoding
PRESET

#

PIN

1

PIN

2

PIN

3

PIN

1

0

0

0

0

2

0

0

0

1

3

0

0

1

0

4

0

0

1

1

5

0

1

0

0

6

0

1

0

1

7

0

1

1

0

8

0

1

1

1

9

1

0

0

0

10

1

0

0

1

11

1

0

1

0

12

1

0

1

1

13

1

1

0

0

14

1

1

0

1

15

1

1

1

0

16

1

1

1

1
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Appendix B: DSP Usage Per Processor

SECTION 12

The following table lists the percentage of DSP resources each processor uses. Total DSP resources are determined by
the combination of processors you are using.
Category
Graphic EQs
Parametric EQs

Feedback
Reducers

Delays

Dynamics

Crossovers
Splitter

© 2003 Shure Incorporated

Block Name

Description

% DSP

GEQ10

10 Band Graphic EQ

4.5

GEQ30

30 Band Graphic EQ

9.8

PEQ 3

3 Band Parametric EQ

2.6

PEQ 5

5 Band Parametric EQ

3.2

PEQ 7

7 Band Parametric EQ

3.7

PEQ 10

10 Band Parametric EQ

4.5

PEQ 3 + CS

3 Band Parametric EQ with Cut/Shelf Filters

3.2

PEQ 5 + CS

5 Band Parametric EQ with Cut/Shelf Filters

3.7

PEQ 7 + CS

7 Band Parametric EQ with Cut/Shelf Filters

4.2

PEQ 10 + CS

10 Band Parametric EQ with Cut/Shelf Filters

5.0

CUT/SHELF

High and Low Cut/High and Low and Shelf Filters

3.4

DFR 5

5 Band Digital Feedback Reducer

14.3

DFR 10

10 Band Digital Feedback Reducer

15.9

DFR 16

16 Band Digital Feedback Reducer

17.8

ST DFR 5

Stereo 5 Band Digital Feedback Reducer

28.6

ST DFR 10

Stereo 10 Band Digital Feedback Reducer

31.7

ST DFR 16

Stereo 16 Band Digital Feedback Reducer

35.5

DLY 5ms

5 ms Maximum Delay

4.7

DLY 150ms

150 ms Maximum Delay

4.7

DLY 500ms

500 ms Maximum Delay

4.7

DLY 2s

2 Second Maximum Delay

4.7

COMP

Compressor

2.6

Sft COMP

Compressor - Soft Knee Option

2.9

ST COMP

Stereo Compressor

5.2

Sft ST COMP

Stereo Compressor - Soft Knee Option

7.0

LIM

Limiter

2.6

Sft LIM

Limiter - Soft Knee Option

2.9

ST LIM

Stereo Limiter

5.2

Sft ST LIM

Stereo Limiter - Soft Knee Option

7.0

AGC

Automatic Gain Control

7.7

GATE

Gate

3.1

DOWN EXP

Downward Expander

3.1

PEAKLIM

Peak Limiter

3.7

DUCK

Ducker

3.9

SUB

Subwoofer

3.2

XOVER 2

2-way Crossover

4.5

SPLIT 2

2-way Splitter

0.0
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SECTION 13

Appendix C: File Extensions

The following table lists the extensions of all of the different types of files created by the DFR22 software.
File Extension
.agc

© 2003 Shure Incorporated

Source
Automatic Gain Control

.backup

Total Device Backup

.cdk

Input and Output Gain

.comp

Compressor

.cutshf

High and Low Cut/High and Low Shelf Filters

.d22

Preset File

.d22pin

Control Pin Configuration

.dfr10

10 Band Digital Feedback Reducer

.dfr16

16 Band Digital Feedback Reducer

.dfr5

5 Band Digital Feedback Reducer

.dly150ms

150 ms Maximum Delay

.dly2s

2 Second Maximum Delay

.dly500ms

500 ms Maximum Delay

.dly5ms

5 ms Maximum Delay

.duck

Ducker

.exp

Downward Expander

.gate

Gate

.geq10

10 Band Graphic EQ

.geq30

30 Band Graphic EQ

.lim

Limiter

.mix

Matrix Mixer

.peaklim

Peak Stop Limiter

.peq10

10 Band Parametric EQ

.peq10cs

10 Band Parametric EQ with Cut/Shelf Filters

.peq3

3 Band Parametric EQ

.peq3cs

3 Band Parametric EQ with Cut/Shelf Filters

.peq5

5 Band Parametric EQ

.peq5cs

5 Band Parametric EQ with Cut/Shelf Filters

.peq7

7 Band Parametric EQ

.peq7cs

7 Band Parametric EQ with Cut/Shelf Filters

.softcomp

Compressor with Soft Knee Option

.softlim

Limiter with Soft Knee Option

.softstcomp

Stereo Compressor with Soft Knee Option

.softstlim

Stereo Limiter with Soft Knee Option

.stcomp

Stereo Compressor

.stdfr10

Stereo 10 Band Digital Feedback Reducer

.stdfr16

Stereo 16 Band Digital Feedback Reducer

.stdfr5

Stereo 5 Band Digital Feedback Reducer

.stlim

Stereo Limiter

.sub

Subwoofer

.xover2

2-way Crossover

DFR22 Software Guide

111

Appendix D: Troubleshooting Guide

SECTION 14

Communication fails between the computer and the DFR22:
The following messages are displayed when the DFR22 software fails to communicate with the device.

“COM(port) is already in use or does not exist...”
This message appears under the following conditions:

•

The specified COM port is already in use by another application.
If the COM port selected is already in use by another application, closing that application will resolve the
problem. An example of an application that keeps the COM port open is HotSync Manager and similar utilities used for synchronizing the computer with Palm Pilot™ type devices. Closing these programs might be
difficult as they usually run as background applications. Consult the program's user manual. Desktop computers usually have more than one physical serial port. In this case, selecting a different COM port and
connecting the serial cable for the P4800 connection to a different serial port might solve the problem.

•

The computer’s serial port is disabled.
Run the BIOS setup utility and enable the serial port. When doing so, note the serial port settings (IRQ and
I/O address) and make sure there is a Windows COM port mapped to those settings. Then choose that
COM port in the DFR22 software.

“Network not ready...”
This indicates that the DFR22 software successfully opened the COM port but did not find a device connected
to it. Make sure the DFR22 is powered on and has finished its boot up sequence before attempting to communicate with the unit. If your computer has more than one COM port, verify you have connected the network
cable to the same COM port that you selected in the “Select COM Port” dialog.
Verify that you are using a serial cable with the correct wiring and that it is securely connected to both the computer and the DFR22. See the Installation Guide for more information.

“No devices detected...”
The DFR22 software has found a device other than a DFR22 in the selected COM port. This may be a modem
or other serial device, such as a DFR11EQ. Selecting a different COM port to which the P4800 unit is connected will resolve this problem.

DFR22 preset indicator displays the letter “E” followed by a number:
•

A corrupted preset exists in the device memory, which must be deleted. If the problem persists after you
follow the instructions below, contact Shure's Applications Group.
To delete corrupted presets:

•

1.

Open the DFR22 software and, in Design Mode, select [File>Delete Preset].

2.

Delete any presets that show up as “**corrupted**.” If the live preset proves to be the offending preset,
click [Cancel].

3.

Select [File>New>Blank] to generate a blank preset, then select [File>Store Preset] and overwrite the
corrupted Live preset with the blank preset.

The firmware update process has been interrupted, which can be corrected by following the instructions
below. If the problem persists, contact Shure's Applications Group.

© 2003 Shure Incorporated

DFR22 Software Guide

112

To complete the firmware update:

•

1.

Cycle power to the device.

2.

From the [File] menu select [Firmware Upgrade].

3.

When the software prompts you to update the code, click [Continue].

As a last resort, perform a hard reset. This deletes all presets and settings from the device and returns it to
its default state.
To perform a hard reset:
1.

Power off the device.

2.

Hold down the Row A Press to Lock/Hold to Clear and Bypass buttons while the DFR22 powers up.

3.

The preset indicator will count down as the reset takes place.

Unable to switch device presets from the computer:
•

Check the device's security level. In order to switch presets from the computer, the device must be set
either to security level 1, or customized level 2. For more information, refer to the Security section on
page 98.

•

If preset changes via control input pins are enabled, the unit will not respond to preset changes via the
software. To solve the problem, disable the control pins for preset change in the “Control Pin” window. For
more information, refer to the “Pin Configuration” section on page 91.

Unable to switch presets from the device’s front panel:
•

The 5th DIP switch on the rear panel of the device is in the down position. Flip it up to unlock the front
panel controls.

•

Front panel lockout is enabled for the preset selector in the DFR22 software. Select [Security>Front
Panel Lockout] from the main menu and de-select the [Preset selector] checkbox in the “Front Panel
Lockout” dialog.

•

If preset changes via control input pins are enabled, the unit will not respond to preset changes via the
front panel. To solve the problem, disable the control pins for preset change in the “Control Pin” window.
For more information, refer to the “Pin Configuration” section on page 91.

© 2003 Shure Incorporated

DFR22 Software Guide

113

